Help for a Linux Newbie on Installing

2004-10-11
2013-04-11
  • Nobody/Anonymous

    I love Freemind!  I have been using it in Windows XP, and I want to install it on my Linux box (Mandrake 9.2).  I believe I have installed Java Runtime Environment 1.5 properly (it took me a couple of times to get it) and I have downloaded the Freemind zip file containing the Linux binaries, but I can't get past a problem.   I have most likely done something wrong somewhere.  Can anyone help?  Here is what I get when I try to run the freemind.sh file (this looks like a problem with Java):

    [root@localhost free]# ./freemind.sh

    ./lib/freemind.jar
    java.lang.NoClassDefFoundError: javax/swing/JFrame
       at java.lang.ClassLoader.defineClass0 (ClassLoader.java)
       at java.lang.ClassLoader.defineClass (ClassLoader.java:179)
       at java.security.SecureClassLoader.defineClass (SecureClassLoader.java:33)
       at kaffe.lang.AppClassLoader$JarSource.findClass (AppClassLoader.java:143)
       at kaffe.lang.AppClassLoader.findClass (AppClassLoader.java:291)
       at java.lang.ClassLoader.loadClass (ClassLoader.java:142)
       at java.lang.ClassLoader.loadClass (ClassLoader.java:121)
       at kaffe.jar.ExecJarName.main (ExecJarName.java:55)
       at kaffe.jar.ExecJar.main (ExecJar.java:75)
    [root@localhost free]#

     
    • Eric L.

      Eric L. - 2004-10-11

      Hi,

      I'm not positive about this, but I think the problem is that you're using kaffe, which doesn't provide all of java.
      You would need to install java from Sun or Blackdown, or make sure that kaffe is not called when 'java' is called.

      If you give me the answers to the questions in the "Freemind under Linux" section in http://eric.lavar.de/comp/linux/freemind/, I might be able to give you more help (installing the Mandrake RPM is recommended but not mandatory).

      Cheers, Eric

       
    • Nobody/Anonymous

      Hi Eric,

      Thanks for your helpful input. 

      I believe that I am not installing JRE and/or JSDK properly (and telling Linux where Java is).  Using the "which java" and "java -version" commands, I have learned that the system says that the Java version is Kaffe, and it is located in a directory where I did not install JRE (or JSDK-- I installed this too).  I thought I identified the JSDK  location (and similarly JRE too) properly by the following commands, but I am probably doing something wrong.  The directory I had intended to install JSDK/JRE to is /usr/local/free.

      [root@localhost free]# export JAVA_HOME=/usr/local/free/j2sdk1.4.2_06
      [root@localhost free]# export PATH=$PATH:/usr/local/free/j2sdk1.4.2_06/bin

      If you can give me some direction on what to do at this point, I should be able to proceed to getting JRE installed and then move on to installing FreeMind.  Thanks.

      Cheers,

      Ron

       
    • Eric L.

      Eric L. - 2004-10-13

      Hi,

      I'm not used to Mandrake, so adapt to your case, but I think Mandrake has a mean to manage RPM packages (look for something like RPM/software/package manager or similar).
      - if you can install the Sun or Blackdown JRE from there, you're done and you can install the freemind package from my homepage.
      - if you can't, you can download and install the J2RE 1.4.2 RPM package from Sun's page (link "Download J2SE JRE" on http://java.sun.com/j2se/1.4.2/download.html, chosing the RPM option).
      - I would remove the kaffe package using the same rpm manager.
      - and as described on my page, set JAVA_PATH correctly and then install the freemind package.

      Hope this helps,
      Eric

       
    • Nobody/Anonymous

      Hi Eric,

      I am just about there.  I am now able to run FreeMind from a console, and I would say I am 90 percent on my way.  Thank you for all your help. 

      I still need some very basic help.  I am only able to run FreeMind from a console, and I need to put in the following export commands to make it work.  The following is the commands I must use.

      [root@localhost free]# export JAVA_HOME=/usr/java/j2re1.4.2_06
      [root@localhost free]# export PATH=$PATH:/usr/java/j2re1.4.2_06/bin
      [root@localhost free]# ./freemind.sh

      I would prefer to run FreeMind from an icon on my desktop, but I don't seem to be able to identify the correct command.  I thought it would be:

      '/usr/local/free/freemind.sh'

      This does not work with the KDE desktop I am using.   If I must run from a terminal, I would like to know how can I set up Linux so that I don't have to run the export commands I have identified above (on each fresh start in a new terminal) .

      OTHER OBSERVATION

      Please note that I also downloaded the FreeMind rpm file for Mandrake 10 from your webpage (remember I have Mandrake 9.2).  I double clicked on it in KDE, and it appeared to install (I don't believe that it would install with the Drake RPM tool).  Now, it appears that I can run FreeMind by typing freemind at the prompt, but I still need to run the export commands.

      You have helped a lot so far, and I need just a little basic help now.  So, I would appreciate just a little more assistance.

      Thanks!!

      Best regards,

      Ron

       
      • Eric L.

        Eric L. - 2004-10-14

        Hi,

        yes, you're almost there:

        - add the two export commands to /etc/profile and/or /etc/bash.bashrc (as root) and you're done.
        Alternatively, you can read "man freemind" and write the two export commands in /etc/freemind/freemindrc (for everybody) or ~/.freemind/freemindrc (only for your user). This is a special from the RPM package.

        - RPM seems to have installed successfully, you can remove freemind from /usr/local/free, you'll have two advantages:
          1. under KDE and Gnome, there should be a menu item for FreeMind (under Applications, if I remember well).
          2. you can call freemind by just typing "freemind" in the Alt-F2 command line.

        Cheers, Eric

         
    • Nobody/Anonymous

      Hi Eric,

      Things are looking GREAT, and I thank you for all the help.  I put the export commands in my etc/profile file, and now I can start up FreeMind with Alt-F2 or from an icon.  I did not remove freemind from usr/local/free yet, but I renamed freemind.sh to ronfreemind.sh (I assume this is enough to get the same effect as removing freemind).  I can't find FreeMind in the menu, but I wonder if this is due to the menu structure being different in Mandrake than in many other distributions.

      One thing I did notice is that when I run FreeMind using Alt-F2, the program simply runs.  However, when I run it from an icon in KDE, I get the program and I get a console window in the background.   It has the following while FreeMind runs:

      Looking for user properties:
      /home/ron1/.freemind/user.properties

      User properties found.
      Default (System) Look & Feel: javax.swing.plaf.metal.MetalLookAndFeel

      The command I have put in the icon properties (execute tab) is freemind.

      Is there any way to not have the console appear when running from the icon?

      In the meantime, I am busily creating maps for a project I am working on, and I thank you very much.

      Please let me know about the console and menu issues.

      Thanks.

      Best regards,

      Ron

       
    • Nobody/Anonymous

      Hi Eric,

      I have an update.  Good news.  I was able to add a menu item for FreeMind.  I then used it to create an icon in a child panel, and then I copied that icon into an icon on the desktop.  When I run any of these, I do not get a console appearing at the same time.  So, I think I am there!

      Thank you so much for your assistance and kindness!

      Best regards,

      Ron

       
      • Eric L.

        Eric L. - 2004-10-15

        Thanks for saying thanks (it's not always obvious).

        My pleasure,
        Eric

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks