Bug: Export to OpenOffice.org does not work

2009-03-16
2013-04-11
  • Simon Brouwer

    Simon Brouwer - 2009-03-16

    Hi

    I noticed that export to OpenOffice.org document does not work (version 0.8.1).
    The document is reported to be damaged and OpenOffice.org cannot repair it.

    If you rename the file to .zip and open it (OpenOffice.org documents are actually .zip archives)
    then you can see why: it only contains a single file called content.xml.

    A proper .sxw file should contain a number of other files and directories besides this file.

    When these other components are copied from a boilerplate .sxw file into the exported file, and it is renamed to .sxw again, 
    then OpenOffice.org can read it without any problem.

    I hope that with this information the bug can be easily fixed.

     
  • David Lettvin

    David Lettvin - 2010-02-13

    I was looking for the answer to the same question. OO says that the .sxw file is corrupted and recommends that it not be repaired. If you choose to repair it anyway it fails again and says that it cannot be repaired.

    A related problem is that there is no documentation for this export within the documentation.

     
  • David Lettvin

    David Lettvin - 2010-02-13

    It's not that there isn't a workaround … Export to HTML, copy and paste. It's just that the export option is there and NOT grayed-out nor documented.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks