Java dependency issues with debian install

  • Nobody/Anonymous

    When I try to install the debian freemind package (on an Ubuntu Linux machine), it complains that it depends on j2re1.4 and java2-runtime which aren't installed. However, I have J2RE1.5 installed, which should be sufficient. Do I have to uninstall that and install the older version, or is there some way to get the package installation to work?


    Output of sudo dpkg -i freemind_0.7.1-1_all.deb:
    Selecting previously deselected package freemind.
    (Reading database ... 70204 files and directories currently installed.)
    Unpacking freemind (from freemind_0.7.1-1_all.deb) ...
    dpkg: dependency problems prevent configuration of freemind:
    freemind depends on j2re1.4 | java2-runtime; however:
      Package j2re1.4 is not installed.
      Package java2-runtime is not installed.
    dpkg: error processing freemind (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:

    Output of java -version:
    java version "1.5.0_01"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_01-b08)
    Java HotSpot(TM) Client VM (build 1.5.0_01-b08, mixed mode, sharing)

    Commands used to install J2RE1.5:
    $ sh jre-1_5_0_01-linux-i586.bin
    $ sudo mkdir /usr/java
    $ sudo mv jre1.5.0_01/ /usr/java/
    $ sudo chown -R root:root /usr/java/jre1.5.0_01/
    $ sudo ln -s /usr/java/jre1.5.0_01/bin/java /usr/bin/java
    $ sudo ln -s /usr/java/jre1.5.0_01/bin/java_vm /usr/bin/java_vm

    • Nobody/Anonymous

      Answering my own question here, but it may be useful for others...

      I figured it would work since I have J2re1.5 installed, and so I ignored the dependency issues with the command:
      sudo dpkg -i --force-depends freemind_0.7.1-1_all.deb

      Works fine except the toolbars are a little bigger than my screen.


      • Eric L.

        Eric L. - 2005-02-02


        I'm happy to went around your problem. Let me just put some further remarks on this topic:

        1. you are using a rather old version of the package, the latest Version is to be found in testing/unstable in the Debian repositories (resp. Revision 5 and 6).
        Sorry for this, I am not able to modify the FreeMind homepage (wink, wink).

        2. the dependency problem is due to the fact that you installed Java without using a package, breaking the dependency mechanism. It's not _very_ bad, it's only a bit bad ;-)
        Java is not packaged per default in Debian, you can use the java-package package to create your own Java package (lots of java and package in this phrase); it's pretty straight forward.


    • Kurt Woodham

      Kurt Woodham - 2005-02-02

      Last post on the subject was correct - since you didn't install JRE1.5 using the package manager (apt or one of the manager interfaces like dselect), and then asked the package manager to install freemind, it wasn't aware that the dependencies were satisfied.

      Here's a link you can use to compile JRE1.5 as a package, then use apt-get to install it.

      I'm using JRE1.4, which is available from Blackdown as a Debian package (I'm using Sarge).  Here are instructions:

      - Kurt


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks