Links doesn't work on Mac

Help
2003-10-29
2013-04-11
  • Nobody/Anonymous

    Hi

    When you create a link in a node and try to open the documents an error occurred.
    "Could not invoke netscape"
    Freemindmap try to open all linked documents with the netscape application.

    It is possible to build d a version that open linked documents on a Mac

    Kind regard

    Eugen Holzenthaler

     
    • Nobody/Anonymous

      I use Freemind on Win2k and Linux.  Worls very well, and I am very satisfied!  I was visiting a collaborator and we tried to install it on her Mac, running OSX (Darwin?).  We installed Java OK, and Freemind seems to work OK.  problem is that when a link is clicked, a "/" is added to the start of the folder/filename, which makes the file inaccessible.  For example a link to docs/anyfile.doc would become /docs/anyfile.doc  Is there any fix for this?

      Robert (r.d.saunders@open.ac.uk)

       
    • Nobody/Anonymous

      No, I have the same issue using OSX/10.3 with URL links not working.

      I don't get any diagnostics when I click on the link, but nothing happens either.

      Is there some configuration clues I can give it about which browser to use and where to find it?

      I get the same issue for mailto links and http ones, but links to other .mm files work fine.

      However:

      THIS IS A FANTASTIC PROGRAM, and I can't imagine being without it anymore.

       
    • Nobody/Anonymous

      Some more details:

      I have enabled the following line in my user.proprties:

      default_browser_command_mac = open -a /Applications/Safari.app {0}

      but still no luck :-(

       
    • Nobody/Anonymous

      I have uncommented this line in user.properties, but still no luck :-(

      default_browser_command_mac = open -a /Applications/Safari.app {0}

       
    • Tony Reid

      Tony Reid - 2004-03-20

      Yep it would be great if someone has an answer to this issue, it's is starting to limit the use of Freemind.
      I can open a url on a mac in browse mode but not mindmap mode. :(

       
    • koh

      koh - 2004-04-02

      Hi!
      I'm Japanese freemind user.
      and I am using freemind on Mac OS X(Panther).

      I'm inconveniently too from this problem.

      Therefore,
      I surveyed sourcecode.
      and I fixed it.

      I already mail to Christian my fixed sourcecode.
      but probably, it is marge and it is released until, time is required a little.

      because if someone want to use fixed version now,
      please DL here,
      http://drikin.com/%7Ekoh/freemind/Mac_OS_X_Freemind_0_7_1a.zip

      but it is my original build, no support, no guarantee.
      I only tested on Mac OS X (10.3.3) only.

      PostScript,

      For I publish my fixed freemind.
      I learned about GPL.
      and I published sourcecode too.
      (http://drikin.com/%7Ekoh/freemind/freemind-src-0_7_1a.zip)

      but If it is problem, please teach me.

      regard

       
      • Nobody/Anonymous

        thanks!!!!
        works good on OSX 10.3 - even so opens linked Documents.

         
    • Nobody/Anonymous

      Thank you for fixing it! However, it seems it only works for http-type links. Linked files dont open, at least in MacOSX 10.2
      Does this happen to you?

       

Log in to post a comment.