freemind.main.FreeMind can't be started

  • Anonymous - 2013-02-24

    After the latest Java upgrade, freemind can't be started.

    Have tested java version "1.6.0_41" and java version "1.7.0_15"

    freemind is ok to open, however it can't open the old .mm files.

    It always pop-up the error messages: freemind.main.FreeMind can't be started

    OS: Windows 7 / 32-bit

  • Anonymous - 2013-02-24

    freemind version: 0.9.0

  • Christian Foltin


    try the latest 1.0.0 RC2.
    Otherwise, please provide a logfile.

    HTH, Chris

  • Anonymous - 2013-02-24

    Have tested 1.0.0 RC2.

    The same error messages while open a old .mm file.

    When I try to open a new .mm file to test, and even more strange. When I input "Test" , it displays 'tseT"


  • Christian Foltin


    thanks for the logs, but they have strange exceptions inside. It seems that some HTML causes difficulties. If it is possible for you to send the map C:/Users/cray/Downloads/FM_201168%20À£¤O«D±`¤ directly to me (I'll delete it ASAP), it would be helpful.
    Another try, is to move the in the .freemind directory temporarily away and to restart FM.

    HTH, Chris

  • Anonymous - 2013-02-24

    I had removed all of the .freemind

  • Christian Foltin

    Do the error only occur with or after loading that map?

  • Anonymous - 2013-02-25

    The error is only happened on the computer that has upgrade to latest Java (Java or Java

    I have another computer and the same file is opened without any problem.

    However, in the Java-updated computer, the errors happen:

    (1) It can't open the previous files at all. It pops up and says "freemind.main.FreeMind can't be started"

    (Double clicking on the .mm files)

    (2) Even remove all of the .freemind, the error is not different. It just can't open the old file well.

    (3) The error is not different from freemind 0.9.0 or freemind 1.0.0 RC2.

    (4) With freemind 1.0.0 RC2, it can be started normally. And, it just can't open the old .mm files at all.

    (5) Although freemind 1.0.0 RC2 can be started, however it will "reverse" the input, that means when we enter "1234ABCD", it will displays and stores "DCBA4321".

    (6) By the way, the new file can be saved and reopened.

  • Anonymous - 2013-02-25

    New finding:

    (7) Not all of the old .mm files can't be started. Some of them can be started and read well. And, those files can be started are all small and simple mind maps. Most of them with size smaller than 5K.

    (8) freemind 1.0.0 RC2 with Java-updated not only reverse the typing, it has some other problems too.

    The "alt-enter" function doesn't work in the freemind 1.0.0 RC2 with latest Java.

    When I enter "alt-enter", it seems to react, however it doesn't pop up the html editor like before Java updates.

  • Anonymous - 2013-02-25

    Now it works.

    I remove all the latest Java 1.6.0_41 and Java 1.7.0_15.

    And, install the previous version 1.6.0_39.

    And, now it can works well with freemind 1.0.0 RC2.


  • Trey

    Trey - 2013-02-26

    I know Cray's discovery is only 2 days old, but any chance the dev team can speak up about when Freemind will work on Oracle's emergency fix?

  • Christian Foltin


    today I tried ot work with Java 1.7.0_15, and I didn't noticed any problems under Linux.

    Can anybody please check under Windows, please.

    TIA, Chris

  • Anonymous - 2013-03-03

    Confirm, too.

    It's All OK to cowork with Jre 7 Update 15 on Windows platform for 1.0.0 RC2.

    The issues in the post are all gone.

    The differences between the previous odd problem is there's *ONLY* Jre 7 Update 15.

    If others have the same problem, the advise is try to update to latest Jre 7 and remove Jre 6. (even Jre 6 Update 39). Then, it should work.

    OS: Windows 7 32-bit (version 6.1.7601)
    Java: Jre 7 Update 15 (Java 1.7.0_15-b03)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks