I have freemind 0.9 and need scripting help

  • mozilla mozillanerd

    When I edit attribute on a node with key=script and value =17+4 and click Evaluate or AltF8 a twirling icon appears and nothing else happens.
    I have tried freeplane with same mindmap and it works with no problem.

    Last edit: mozilla mozillanerd 2013-08-07
  • Christian Foltin

    works for me. Please provide the log file and the map. TIA, Chris

    • mozilla mozillanerd

      The test is a simple freeplane map (which works in freeplane) but does not in freemind. Thanks for answering!.
      Hello World!

        text ok
        text okay

      I attach a script in 3 as follows: {script:=1+2+3} . Nothing happens when I execute the script via Alt F8 or Tools->Evaluate.
      I don't know where the log is.
      Found the log, it is quite lengthly: http://snipt.org/AYjh1

      Last edit: mozilla mozillanerd 2013-08-10
  • Christian Foltin

    Hi, there seems something wrong with your installation, as there is a class missing. How do you install FreeMind?
    TIA, Chris

  • mozilla mozillanerd

    I used ubuntu's Package Manager. This is the first time that I have tried attributes and I was trying to verify that the examples for freeplane worked in freemind.

  • Christian Foltin

    Hi, then, please try the zip-package, unpack and start freemind. I'm interested to know, whether or not this works with the scripting. TIA, Chris

    • mozilla mozillanerd

      I have done it with freemind's zip. Same results


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks