SourceForge has been redesigned. Learn more.
Close

Map corrupt after power cut - how to restore?

Help
mariku
2012-05-19
2013-04-11
  • mariku

    mariku - 2012-05-19

    Hi there,

    fistly: Thanks heaps for Freemind to everyone contributing to it, it is my by far favourite piece of productivity software.

    I ran into a problem that I hope someone may be able to help me solve; also wanted to give this as feedback in case it is useful for further development.

    I am running Linux Mint 12 LXDE (which I can only highly recommend!) on an oldish laptop, and have been using Freemind on this without problems for quite some time.

    Yesterday, I unplugged the power supply from the laptop and continued working on battery power. I remember I couldn't reach the plug at the back of the laptop properly where the laptop was at the time, and I may have jiggled it a few times while pulling it out, possibly causing intermittent contact - no contact cycles.

    The power management of Linux Mint 12 LXDE did not detect that the power supply was unplugged, and thus did not behave in the way it normally would when battery runs empty (save stuff, shut down normally and safely). The fault that the power management didn't detect the loss of grid power lies with Linux Mint, I would assume.

    I made the mistake of waiting too long before shutting down manually, and so the laptop shut down without warning from on to totally dead in half a second, as if someone had pulled out the battery. My mistake.

    The result was that not only was all unsaved work that I had done on my then open freemind mind map lost - which I would have expected under these circumstances - but, horror, my rather large mind map can not be opened by Freemind AT ALL anymore now!

    When trying to open it, I get the "this mind map was created with an older version of Freemind, should Freemind convert it to the current format?" message. (It has in fact not been made using an older version!) If I click "no", it doesn't open. If I click "yes", the mind map opens, but only has one single bubble which states "javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is not allowed in prolog.".

    Why is that? What does it mean?

    And, most importantly for me: Is there any way I can restore that mind map to what it was at the last save before the power cut?

    Cheers,

    Matt

     
  • Christian Foltin

    Hi,

    first of all, there should be the automatic backups available in ~/.freemind/
    If not, you can have a look into the file or send it to me, and I repair it, if possible.

    HTH, Chris

     
  • mariku

    mariku - 2012-05-19

    Hi Chris,

    fast answer, short answer, solved. Thank you so much! All good, I only lost maybe a couple minute's worth of work, no problem.

    Thanks heaps!

    Matt

     

Log in to post a comment.