v 1.0 Copy as Clone not working on Mac

Help
Tom Lewis
2014-02-27
2015-06-13
  • Tom Lewis

    Tom Lewis - 2014-02-27

    The Copy as Clone menu option is never available on my Mac. It works fine under Windows. Known Error or Bug?

     
  • Christian Foltin

    Hi,

    I think, you mean "Paste as clone". On my mac, it works.
    Can you describe the error a little further, please? Is it gray? (By the way, the menu entry is only enabled, when you've copied some nodes of the same mindmap before, otherwise it is gray).
    Can you provide a log file?

    TIA, Chris

     
  • Kapil Bulsara

    Kapil Bulsara - 2014-09-30

    I am having the same problem. I'm copying a node in a mind map and trying to paste it in a different node in that same mind map.The "Paste as clone" button is gray.

     
    Last edit: Kapil Bulsara 2014-09-30
  • Christian Foltin

    Hi,
    that's strange. How do you copy?
    Br, Chris

     
  • Karl

    Karl - 2015-04-01

    Hello!

    I have the same problem! "Copy as clone" is greyed out.
    Although I am on version 1.0.1 (OSX), I was hoping a solution might have come up related to this post.

    I looked at the log when trying to copy with the shortcut for "Copy as clone" but that did not trigger any action/error message except for the keystrokes being recognized.

    Any ideas?
    Thanks!
    Karl

    P.S.
    I have noticed, that the cloning operation works once after program start. The clones created work fine but it is not possible to create other clones.

     
    Last edit: Karl 2015-04-01
  • Karl

    Karl - 2015-04-18

    any clues?

     
  • Christian Foltin

    Hi,

    did you try to copy and paste-as-clone both with the menu? And on the other hand, did you try to do both by keystrokes? Important: same mindmap, copy only one node (don't use copy single).

    HTH, Chris

     
  • Karl

    Karl - 2015-04-19

    Hi!

    yes, same map, no-single copy, and I have tried this with both shortcut alt+cmd+v and via menu.

    As I said earlier, it works once. Just after opening freemind. As soon as the first clone is performed, the menu item is greyed out. & It is not dependent on opening or closing a single file, nor on whether I am using a new file or one, that was converted from Freemind 0.9.

    Maybe a problem of the setup?
    Running OSx 10.9.5

    I downloaded the 1.0.1 and dragged it to my programs folder. I have also deleted the 0.9 version.

    Java-Version, as seen in Systems-Settings is: Version 8 Update 40 (Build 1.8.0_40-b27)

    Thanks for any help!
    Cloning sounds so good...

     
  • Christian Foltin

    Hi,

    on my system, I use java7. Do you want to give it a try?
    Or try this:
    New map
    childs a,b,c
    copy c
    paste as clone into a
    paste as clone into b --> is that possible?

    BR, Chris

     
  • Karl

    Karl - 2015-04-21

    I did the a,b,c test with a new map and freshly opened freemind. It works for "paste as clone into a" but then ceases to work for "paste as clone into b".

    I will give java 7 a try next week.
    All the best,
    Karl

     
  • Karl

    Karl - 2015-05-07

    I have solved the cloning problem!

    It does seem to be connected to Java but I am not quite sure whether all the steps I took where necessary. Maybe someone who knows Java can sort out the necessary ones:

    1. From what I could see in the "System-Preferences" my system was running Java RE 8 Update 40. In Terminal however, when I called "java -version" my system seemed to be running version 6 (1.6.x.x.). Installing JRE 8 update 45 did not change this.
    2. I installed the Java Development Kit 8 as this would set the Java home-Variable to Java 8. After installation, calling "java -version" in terminal provided version "1.8.0_45".
    3. Still no cloning in Freemind.
    4. I looked at the info.plist file in the Freemind package (/Applications/Freemind->right-click-> "Show package content")
      In the file I deleted the following lines (after inserting my Java-Version did not help):
      <key>JVMRuntime</key>
      <string>jdk1.7.0_45.jdk</string>
    5. Freemind now clones without problems.

    All the best
    Karl

    P.S. Running OSx 10.9.5

     
    Last edit: Karl 2015-05-07
    • Joe Antkowiak

      Joe Antkowiak - 2015-06-13

      This worked for me. It also corrected several other issues, including the rubber-banding/scrolling issue.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks