Freemind doesn't start on Windows 7 (x64)

  • Gert Van Meerbergen


    I've just installed Freemind on Windows 7 64-bit.  I've checked the Java installation via and it indicates that I've installed Version 6 Update 15. (BTW This check only works with the x64 version of Internet Explorer.)

    If I then want to install Freemind, I get the message that Java 1.4 or higher needs to be installed. I can continue to install Freemind but when I want to start the application nothing happens.

    Next I've tried to start the application using the freemind.bat. That seems to work but I get the messages below. Is there a solution for this so that I can start Freemind using the "freemind.exe"?




    Looking for user properties:

    User properties found.
    Default (System) Look & Feel:

    [Freemind-Developer-Internal-Warning (do not write a bug report, please)]: Tried to get view without being able to get map module.
    7-aug-2009 16:44:48 freemind.modes.ModesCreator getAllModes
    INFO: Modes:[freemind.modes.browsemode.BrowseMode, freemind.modes.filemode.FileMode, freemind.modes.mindmapmode.MindMapMode]
    7-aug-2009 16:44:48 freemind.modes.ModesCreator getMode
    INFO: Initializing mode MindMap
    User patterns file C:\Users\gert\.freemind\patterns.xml not found.
    7-aug-2009 16:44:48 freemind.modes.mindmapmode.MindMapController <init>
    INFO: createIconActions
    7-aug-2009 16:44:48 freemind.modes.mindmapmode.MindMapController <init>
    INFO: createNodeHookActions
    7-aug-2009 16:44:49 freemind.modes.mindmapmode.MindMapController <init>
    INFO: mindmap_menus
    7-aug-2009 16:44:49 freemind.modes.mindmapmode.MindMapController <init>
    INFO: MindMapPopupMenu
    7-aug-2009 16:44:49 freemind.modes.mindmapmode.MindMapController <init>
    INFO: MindMapToolBar
    7-aug-2009 16:44:49 freemind.modes.mindmapmode.MindMapController <init>
    INFO: setAllActions
    7-aug-2009 16:44:49 freemind.modes.ModesCreator getMode
    INFO: Done: Initializing mode MindMap
    7-aug-2009 16:44:49 freemind.controller.MainToolBar setZoomComboBox
    INFO: setZoomComboBox is called with 1.0.
    7-aug-2009 16:44:49 freemind.extensions.HookFactory getClassLoader
    INFO: file .\plugins\time\time_plugin.jar exists = true
    7-aug-2009 16:44:49 freemind.extensions.HookFactory getClassLoader
    INFO: file .\plugins\time\jcalendar.jar exists = true
    7-aug-2009 16:44:49 freemind.modes.mindmapmode.MindMapController startupController
    INFO: mScheduledActions are executed: 3
    7-aug-2009 16:44:49 freemind.modes.ControllerAdapter registerMouseWheelEventHandler
    INFO: Registered   MouseWheelEventHandler accessories.plugins.UnfoldAll$Registration@78a974c7

    • D. Davis

      D. Davis - 2009-08-21

      I had this exact problem. It worked for me to change the Freemind shortcut Target property so that it points to the jar file instead of the exe:

      "C:\Program Files (x86)\FreeMind\lib\Freemind.jar"


    • Man Pak Hong

      Man Pak Hong - 2013-04-22

      You need to set %JAVA_HOME% and path to point to x64 java.

      A. Set Java home
      1. Right-click My Computer
      2. Advanced
      3. Environment Variables
      4. System variables ---> New
      5. At New System Variable, type Variable name: JAVA_HOME, Variable value: point to the x64 java home path, my one is : <C:\\Program Files\\Java\\jdk1.7.0_17="">
      6. OK

      B. Set Java bin to Path
      1. find Path at System variables
      2. Edit
      3. At variable values: append ";%JAVA_HOME%\bin;"

      C. run FreeMind
      1. find the install path of FreeMind (It is x86, 32-bit software, It is located at "C:\Program Files (x86)\FreeMind\"
      2. run "Freemind.bat" instead of "Freemind.exe"
      3. if you want to make it at desktop, make a shortcut of "Freemind.bat" instead of "Freemind.exe"

      Man Pak Hong, Dave

  • pascal

    pascal - 2009-11-05

    I encountered the same problem. You need to install the 32 bit JRE.

  • zwooosch

    zwooosch - 2009-11-17

    My Freemind isnt starting, too.

    Iam using WIndows 7 64bit Version, Tried installing newest Java in 32bit and or 64 bit version. After starting the exe or bat file. javaw is using up to 50 % cpu power (AMD X2 250 2x3.0Ghz here) and nothing more happens.

    When starting the 0.9 bat file the program shows "checking for java version for like 2 minutes before proceeding.

    i tried freemind 0.9 and 0.8 with same results.

    starting the jar file doesnt helps too

        java version "1.6.0_18-ea"
        Java(TM) SE Runtime Environment (build 1.6.0_18-ea-b04)
        Java HotSpot(TM) 64-Bit Server VM (build 16.0-b11, mixed mode)

    actually its looking like the program started after 2 minutes as the java icon is appearing in the "dock" but i cant see freemind appearing on the screen.

    other tools like jEdit ar working fine.

  • Martin Iturbide

    Martin Iturbide - 2009-11-27


    Im using the last version of FreeMind on Windows 7 Ultimate x64. I have never got the problem that you are telling.

    Did you get the lastest Java JRE for Windows in 64bits ?


  • Ron Matthews

    Ron Matthews - 2009-11-28

    I guess I'm dumber that I thought I was.

    I'm having the same problem with not being able to get Freemind to launch on my Windows 7 Pro 64-bit platform.

    I read martiniturbide's post about getting Java JRE for Windows in 64bits, so I went to and spent an hour trying to figure out how to find the 64-bit JRE for my platform.

    Either the download I need does not exist, or I have absolutely no idea how to find it on Sun's page.

    If there is anyone reading this forum who really and truly knows where I can find the necessary files to get Freemind to run (really and truly - not sort of, maybe), and is willing to direct me, I would deeply appreciate it.

    Thank you (really and truly),


  • Eric L.

    Eric L. - 2009-11-28

    The page given by martiniturbide is the correct one, just click on the Download button next to "Java SE Runtime Environment (JRE)
    / JRE 6 Update 17", then select the right platform "Windows x64".


  • Sonny Ramsay

    Sonny Ramsay - 2010-03-31

    Try running the 32-bit version of JRE.

  • evertvk

    evertvk - 2010-10-06

    I had the same problem on Windows 7 x64, with Java JRE 6_21 64-bit installed. Just setting JAVA_HOME and PATH environment variables in Windows to  C:\Program Files\Java\jre6\bin\ did the trick for me. I then could start Freemind from the Start menu.

  • evertvk

    evertvk - 2010-10-08

    Even better: if you install it in e.g. c:\programs instead of c:\program files (x86), you don't get the UAC pop-up when you start freemind.

  • Peter Tandler

    Peter Tandler - 2011-08-26

    evertvk, thanks for the hint with the UAC popup! This is really an easy work around that works fine (on my windows 7 64 bit)

  • Ross Marsden

    Ross Marsden - 2011-10-13

    I'm using Win XP, I have Java 6 update 26, and just installed FreeMind 0.9.0.
    As first it did not start. No error dialog or anything.
    I added the path to the current Java version BIN directory (where JAVA.EXE is) on a long shot.

    And now it starts OK.
    How hard can it be?

  • DBFZ

    DBFZ - 2012-06-15

    I had the same problem with Windows 7 (x64) and i have resolved the problem with setting up the PATH (windows environment variable) to the "bin" directory of java. So I've solved it like evertvk (10).

  • Anonymous - 2012-08-01

    Adding Java "bin" directory to PATH also helped me.

  • Franck

    Franck - 2012-08-15

    i also added the directory to PATH and it worked. Thks.

  • Anonymous - 2012-08-21

    It worked for me running with elevated priviledges. Run as Administrator and should work.


Log in to post a comment.