(no subject)

Help
2013-04-26
2013-04-28
  • Daniel Albertsson

    Hi.
    I have been reading up on groovy lately in order to hopefully be able to
    make some scripts in freemind, and I've gathered a fair amount of links
    about it, but I find it rather difficult to get over that first
    threshold of making sense of the documentation and actually getting
    anything to run (I'm not a script- or programming-wiz by any means,
    but I have some experience in bash-scripting at least and understand
    at least some of the basics of programming
    and software-design etc):

    *I have 0.9.0 installed, but some of the features mentioned in the
    documentation about scripting (specifically mentioning 0.9.0) doesn't seem to be present in my version, for example a 'script-editor'
    which should reside in the 'tools'-menu. Also 'evaluate' is not
    available as a menu-command, but only through the shortcuts-menu (I
    tried to change it and set it to different keystrokes, but I cannot get
    any of the sample scripts to evaluate).

    *Since the attributes are mentioned as the place for holding the scripts
    I went to the 'attributes-manager', which weirdly enough shows
    attribute-instances although I tried to remove them (not visible on
    the canvas anymore), and neither the existent or "non-existent" value
    are changeable from the manager, which seems quite odd for a manager.

    *The 'set attributes'-command only seems able to store short one-liners,
    which makes it difficult to even see all of the script text, let alone
    edit it.

    I feel that my basic problem (except for that my post is getting quite
    long) is that I find the documentation not of the scripts or the
    languages themselves so much, but rather the proposed facilities for
    managing them and getting them to work in the program quite elusive.

    If someone is able to point me in the right directions I have some
    interest in making some screencasts, and possibly making the process
    more available for future fledgling scripters like me, and any help
    would be MUCH appreciated.

    PS I use Ubuntu Studio, and the widget-set that makes up the default
    freemind version that gets installed from the repositories seems a bit more
    crude than when I've run it before on "plain vanilla" Ubuntu. Could it be
    that my version is lacking some basic functionality, although the
    version should be correct (0.9.0)?

    Thanks in advance!

     
  • Christian Foltin

    Hi,

    first try the original .zip-version of 0.9.0 (or even better of 1.0.0RC3). It seems that the plugins (and scripting is a plugin) are not present in your version. Additionally, you can send the log file to us.

    HTH, Chris

     
  • Daniel Albertsson

    Hi Chris.
    Thanks for your kind assistance. I installed 0.9.0 and I've so far tried the simplest possible thing (=2+4) and it evaluates just fine. I also tried in the first round to install the 1.0.0-version, but it sadly froze at the splash every time I tried to launch. I guess I'll have to wait a bit until it becomes more stable
    (I would have loved to try it out some more to hopefully figure out and help others figure out the errors since it is a beautiful piece of software, and I would love to contribute in that small way if possible, but my schedule for at least the coming month is only two steps short of insane - hopefully in the summer there will be some more time).

    Regarding the logfiles: There seems to be a bunch of them in the .freemind-directory. If one or several of them are of any help to you I'll be happy to send them (should I just make a post and attach them?).

    *The different attribute-managing-facilities (except the excellent script-editor) are still kind of puzzling, but since I can handle things fine at the moment I'll get back to that at a later time if it becomes relevant.

    Thanks for now and I'll get back if I run into any major problems when trying out the scripting more.

    Regards D.Albertsson

     
  • Christian Foltin

    Hi Daniel,

    we write RC3 of 1.0.0, so it should be pretty stable. Please send me a log file of the starting process of 1.0.0 either directly or attach it here. I would like to know, what the problem is at your place.

    TIA, Chris

     
  • Christian Foltin

    The last log file is named log.0

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks