Freemind RC Builds for Mac are PPC Binaries

  • Eric P. Tiongson

    It turns out that all RC Mac builds have been changed back to PPC builds (as opposed to Universal). 

    I've checked all RC builds and compared them with the latest Beta builds.  Beta builds are Universal while RC builds are PPC.

    I noticed since I upgraded to Snow Leopard and I don't want to install Rosetta anymore.

    Can this be fixed?  and do you guys need any help on this?

  • Christian Foltin


    how did you checked this? Where is the difference?

    TIA, Chris

  • Eric P. Tiongson

    Hi Chris,

    If you mean difference in terms of build/packaging - the only one that matters in this case is the executable named JavaApplicationStub inside  The Beta builds contain the Universal version of JavaApplicationStub while the RC builds contain the PowerPC version.

    OS X (Snow Leopard) prompts me to install Rosetta (and I keep on declining) everytime I try to open any of the RC build, that's how I knew.  I verified it by right-clicking and choosing "Get Info" each of the builds. 

    What I did just now is I copied the JavaApplicationStub from Beta 20 to my (downloaded) RC4 build and it resolved the issue.

    Looks like that's all you need to do - make sure that the correct JavaApplicationStub is packaged with the build.


  • Christian Foltin


    before 0.9.0 beta20 I used a symbolic link to the stub installed at the system FreeMind is installed to:

    <!- Delete the JavaApplicationStub and replace it with a symbolic link ->
      <!-   which should work on older and future versions of OS X
       Taken from  

    fc, 8.10.2008, removed as people reported problems with this:

      <delete file="${dist_macos_contents}/MacOS/JavaApplicationStub"/>
      <exec executable="ln">
        <arg line="-s /System/Library/Frameworks/JavaVM.framework/Resources/MacOS/JavaApplicationStub"/>
        <arg value="${dist_macos_contents}/MacOS/JavaApplicationStub"/>

    But observe, that somebody has its problems with this solution:

    Who is right now? Any opinions from other Mac users?

    Regards, Chris

  • Janĺke Rönnblom

    I think both methods work (the symlink and copying the JavaApplicationStub)

    I run Snow Leopard and got the "install Rosetta" message which I dont want to do. I did copy the JavaApplicationStub from the /System/xxx and replaced the one in FreeMind.

    Now it works!



Log in to post a comment.