Testversion: FreeMind 0.9.0 Beta20

2008-08-29
2013-04-12
  • Christian Foltin

    Hi,

    a regular bug fix release is available.

    Enjoy,

    Chris

     
    • Rafal Machalica

      Rafal Machalica - 2008-08-30

      Hi,

      I can't run this version (on Linux). It complaints lack of some file (I guess freemind.jar)

       
      • Eric L.

        Eric L. - 2008-08-31

        Hi,

        the binary .tar.gz hasn't been uploaded (only the src file), we're in the process of fixing this, be patient.

        Sorry for this, Eric

         
        • Eric L.

          Eric L. - 2008-09-05

          OK, by lack of alternative, I've compiled and uploaded myself the binary package freemind-bin-max-0.9.0_Beta_20.zip

          If something is wrong, blame me, not Chris. You can still blame him that he lets someone like me do his job :-)

          Eric

           
    • Rafal Machalica

      Rafal Machalica - 2008-08-31

      No problem. Good to know that nothing's wrong on my side. Thanks for info!

      BTW - is there any repository of all old Betas? On Sourceforge there is always only the latest one. In cases like this, it would be handy to be able to get previous working version (recovery from Trash Bin is not safe solution ;-) This may be even more dangerous on Windows version (which I use as well) with installer, which (presumably) overwrites old installation. I realize that this is test version, but I couldn't resist from switching to 0.9 branch for all these new excellent features :-)

       
      • Eric L.

        Eric L. - 2008-09-04

        All versions of 0.9.0Beta are still on SF, you just need, in the Download section, to click on the freemind-unstable package link, instead of clicking directly on the version itself. The older versions are linked and you only need to click in order to roll them down.

        Eric

         
    • Pete Carapetyan

      Pete Carapetyan - 2008-09-24

      Tools > Preferences seems to be broken, here are the two reports of 9beta20 on both Windoze XP and Vista

      On my Windoze XP box, Tools > Preferences just goes into lala land. Nothing happens, and if I click anything in freemind it just beeps, the application is essentially useless to me until I shut it down using TaskManager. Not a good thing.

      On my Vista64 box Tools > Preference just does nothing, but the app is still usable.

       
      • Hth

        Hth - 2008-09-25

        Here it works without problems.
        Win XP SP2 German
        Freemind setting language automatic (->German) and En.

        Yours
        Alexander

         
        • Pete Carapetyan

          Pete Carapetyan - 2008-09-25

          I would be happy to help with any other testing to see why 9beta20 is broken on both of my boxes on Tools > Preferences, can you think of any other things to try ?

          Is anyone else having these issues ?

           
    • Meccano2006

      Meccano2006 - 2008-09-25

      Mine also works without problems.
      Win XP SP2 Italina
      Freemind setting language English

      Meccano

       
    • gregarn

      gregarn - 2008-09-25

      Tools>Preferences works normally on this XP SP2 machine also.   Which version of JRE?   Tried to reinstall FM? 

       
      • Pete Carapetyan

        Pete Carapetyan - 2008-09-25

        > Which version of JRE?

        java version "1.6.0_07"
        Java(TM) SE Runtime Environment (build 1.6.0_07-b06)

        >Tried to reinstall FM? 

        Re installed fresh several times both XP and vista machines, of course. Just in case.

        Here is the log entry, trying to figure that out next

        STDERR: Exception in thread "AWT-EventQueue-0"
        STDERR: java.lang.IllegalArgumentException: Cannot set a boolean to false
        STDERR:     at freemind.common.BooleanProperty.setValue(BooleanProperty.java:83)
        STDERR:     at freemind.preferences.layout.OptionPanel.setProperties(OptionPanel.java:152)
        STDERR:     at freemind.controller.Controller$PropertyAction.actionPerformed(Controller.java:1472)
        STDERR:     at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
        STDERR:     at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
        STDERR:     at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
        STDERR:     at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
        STDERR:     at javax.swing.AbstractButton.doClick(Unknown Source)
        STDERR:     at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
        STDERR:     at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
        STDERR:     at java.awt.Component.processMouseEvent(Unknown Source)
        STDERR:     at javax.swing.JComponent.processMouseEvent(Unknown Source)
        STDERR:     at java.awt.Component.processEvent(Unknown Source)
        STDERR:     at java.awt.Container.processEvent(Unknown Source)
        STDERR:     at java.awt.Component.dispatchEventImpl(Unknown Source)
        STDERR:     at java.awt.Container.dispatchEventImpl(Unknown Source)
        STDERR:     at java.awt.Component.dispatchEvent(Unknown Source)
        STDERR:     at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
        STDERR:     at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
        STDERR:     at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
        STDERR:     at java.awt.Container.dispatchEventImpl(Unknown Source)
        STDERR:     at java.awt.Window.dispatchEventImpl(Unknown Source)
        STDERR:     at java.awt.Component.dispatchEvent(Unknown Source)
        STDERR:     at java.awt.EventQueue.dispatchEvent(Unknown Source)
        STDERR:     at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        STDERR:     at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        STDERR:     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        STDERR:     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        STDERR:     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        STDERR:     at java.awt.EventDispatchThread.run(Unknown Source)

         
        • Pete Carapetyan

          Pete Carapetyan - 2008-09-25

          Thanks Dimitry, this problem was entirely solved by moving away my .freemind directory, a suggestion made not in this thread but in the thread I started to figure out my initial problem, which was how to get past the groovy script not firing.

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks