FreeMind Version 1.0.0 Beta9

<< < 1 2 (Page 2 of 2)
  • tormen

    tormen - 2012-12-08


    echo $CLASSPATH
    ~ % ls /LINKS/java/lib
    ls: cannot access /LINKS/java/lib: No such file or directory

    So the "." is the problem?? …

    It seems so!
    Because it seems to me that the classpathes are searched RECURSIVELY ??!!!
    I would NOT have thought that, but it sure seems so, because:

    With: export CLASSPATH=.

    (a) when I start freemind in my home directory where I have a LOT of subdirs + data -> it takes a long time
    (b) when I go to /tmp where I have not a lot of stuff -> it is quick

    So … I learned something about java… that is STRANGE though, no ?? I would never have thought that the .  or any classpath dir is recursively searched for jar files …

    and btw: In my home dir itsself, I have NO .jar files,
    only in subdirectories:

    find|grep 'jar$'|wc -l

    And ALL of them are from .jdownloader (which installs itself - like Chrome under windows - into my userdir).

    It would be nice to get your feedback about this recursive search behaviour.


    … back to the original question then :)

    I'll try again without any CLASSPATH later and let you know!


  • Christian Foltin

    Hi Tormen,

    no, java doesn't search recursively, you are right. But freemind does. It takes the classpath and searches recusively for jars or xml files in order to find its plugins.

    HTH, Chris

  • Tom

    Tom - 2012-12-10

    Hi Chris, did you receive my mail with the pictures? Can you reproduce that blank-space entrys after converting frrom 0.9 to 1.0.x too? Let me know please if you need anything else!
    Best regards,

  • Gill

    Gill - 2012-12-13

    i also experienced weird behavior where some of the nodes appeared to get additional characters (spaces, new lines), i was looking for any font formatting setting only to find out its the text itself that was modified

    - happened with subnodes of one single node, about third of them
    - i managed to edit them manually

  • tormen

    tormen - 2012-12-14


    Just to let you know: I will test it, but I am in big stress until the 20th so maybe only afterwards :/
    For now I am still running 0.9 ;)

    I have 3 questions:
         Is there a way to CTRL+F search also though LINKED mind-maps ??
         Is there a way to easily link to a node within another mind-map (I only know about a /manual/ way: CTRL+K and then put the filename + ID)… which brings me to my 3rd question:
         What is the easiest  way to get the ID of a node ?

    … and why are bubbles not a physical styles feature like "italic font" just on the one node itsself ?
    That would make bubbles so much more flexibel and useful IMHO.

    But I know that this stuff is off topic… If I could get an answer, I would be happy to repost it (or put Q and R) in the right place :))

    Thanks a lot for everything (starting with the creation of feemind :),


  • Iain Kewley

    Iain Kewley - 2012-12-18

    I've found that when using the Java Applet from v1.00B9 the filtering function no longer appears part of the content of the toolbar and so you can't filter from the web version. Has it moved somewhere or has it been removed?

    I find this software of great use and would be disappointed if this feature was not to be present in future.

  • Christian Foltin

    Hi iainkewley,

    thanks for the hint. I've readded the filter. Currently, this is available only in the git repository, but will be included in the next version.

    Br, Chris

  • Christian Foltin

    Hi Tormen,

    to your questions:
         Is there a way to CTRL+F search also though LINKED mind-maps ??
    * Currently, not.
         Is there a way to easily link to a node within another mind-map (I only
    know about a /manual/ way: CTRL+K and then put the filename + ID)…
    * This is the only way, I know.
    which brings
    me to my 3rd question:
         What is the easiest  way to get the ID of a node ?
    * Hmm, the easiest way would be a groovy script that copies it to the clipboard and to put this script to a pattern and thus to a function key. Can you create such a script?

    HTH, Chris

  • Christian Foltin

    Hi hojokl,

    I didn't understand your report. Can you add some more details, please?
    TIA, Chris

  • Conrad

    Conrad - 2013-01-02


    I tried cloning combined with an encrypted mind map but this does not seems to work: I can make a clone node.  When I save the map and than quit freemind. Than reload the map, unlock the map, the clone became a real copy.  So it is not a clone anymore :s . somebody experience with that?

    Kind regard

  • marter

    marter - 2013-01-03


    Thank you for this new version, but i can't find the fonction "Free Move" the node.

    In the previous version, a click in border node root side was functioned, but now it's not possible or different (?).

    Could you help me ?


  • Christian Foltin

    Hi omarter,
    the free move can be enabled by preferences. I disabled it, as I thought, that it might irritate lots of new users. Whats your opinion?

    Br, Chris

  • marter

    marter - 2013-01-04


    Thank you for your answer.

    For my opinion, i used very often the free move function to ajust and personnalize the final layout.
    I like this function and allows to customize the map. For example :
    - to do a landscape or portrait layout
    - to use area 360° arround the main node
    - to manage the space between two nodes

    In the previous Freemind version (when the free move was enable), maybe this function was not ergonomic.

    Br, Olivier

  • Gill

    Gill - 2013-01-19

    i was talking about issue crxtom pointed out above my last message - the blank-space entries

    opening 0.9 map in 1.0b9 changed some of my nodes' text - they had additional space characters that i had to manually delete one by one - very irritating, if this happened to lots of nodes (it happened to maybe 20) it could be a serious issue

  • Carl Brusse

    Carl Brusse - 2013-01-21

    Surely this is a bug:

    I start with 4 nodes: test1, test2, test3, & host. I copy test1, test2 & test3 (at the same time) and paste them as clones into 'host'. I give them different attributes to test the cloning (all good). I then start moving the clones around relative to each other. When I do, the originals start multiplying. Eg drag and drop cloned test1 onto cloned test2 as a daughter node and then move it back to the same level, and a new test1 node pops into existence among the original test 1-3 nodes. Move them around like a shell game and the same thing happens, though intermittently. The screenshotted map above was produced by simply moving the clones around: no copying and pasting was carried out beyond the initial cloning. Is this behavior reproducible by others? Surely it's not desirable?

    Using Freemind 1 b9 Max, downloaded as zip.

  • Christian Foltin

    Dear Carl,

    please verify with the dmg-version of 1.0.0 b9, as I don't have this behaviour here, and it was fixed between b8 and b9.
    If not, please describe the steps in more detail.

    HTH, Chris

  • Carl Brusse

    Carl Brusse - 2013-01-21

    Thanks Chris. I was indeed using beta9, downloaded earlier today (writing from Australia) in the Max zip and was running it on Windows 7 on my office machine. I can reproduce the issue now with the beta9 windowsMax installer running on my Windows 7 laptop.

    Here are the steps I follow.

    1: ctrl-N for a new map and create four nodes (test1, test2, test3, host)
    2: select and copy the first three nodes and clone-paste as daughters under host
    3: assign physical styles to the pasted clones
    4: drag-drop test1 clone to be daughter of test2 clone
    5: drag-drop test1 clone back to where it was
    6: drag-drop test2 clone above test1 clone
    7: drag-drop test3 clone above test2 clone
    result is here :

    (replace the 7 in that URL with 1-6 to see the results of each step- the spam filter won't let me add them even as inline img)

    further clue (?): if I hit ctrl-z undo after step 4, I don't get what was in step 3: test1 clone disappears (png is 8).

    anyway thanks again for the reply and I hope this helps (I would love to be able to use the clone feature without worrying about this sort of strangeness). Perhaps it\'s a Windows thing? Also, I have note tried wiping my .freemind folder before the beta9 install, so I might try that tomorrow to see if it makes a difference (bedtime now).

  • Christian Foltin

    Dear Carl again,

    thanks for your work. I tried it with my git version, and the bug is corrected. So, take the version from git repository, or please wait some days until RC1 will appear.

    HTH, Chris

<< < 1 2 (Page 2 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks