#21 Click on link launches IE rather than default browser

closed
nobody
None
5
2004-01-27
2003-05-02
Anonymous
No

Running under Win2000 in "standalone mode" (i.e.,
started with FreeMind.exe), if I click on a hyperlink,
Internet Explorer is used to display the page, even
though Phoenix is my default browser.

When running as an applet (for example, when viewing
the samples on the FreeMind page), my default browser
is properly invoked.

I haven't seen this behavior with most other programs
(Microsoft's programs usually do this, but that's to be
expected).

Discussion

  • Daniel Polansky

    Daniel Polansky - 2003-06-07

    Logged In: YES
    user_id=625500

    That's correct. Implementing links so that they worked was a
    difficult work. It would be nice if default browser would be
    properly invoked.

     
  • Christian Kremser

    Logged In: YES
    user_id=688001

    I was wondering about a similar problem for quite some time.
    I'm running WinNT and after clicking a hyperlink I always
    get the error: "Could not invoke browser." Finally I looked
    at the source and found in FreeMind.java, function
    openDocument, that there is a so called explorer_command
    variable which for WinNT, and thus also for Win2000, is set
    to "C:\\Program Files\\Internet Explorer\\iexplore.exe".
    That is the reason why in your case Internet Explorer is
    always launched. In my case the IE resides in a different
    directory "C:\\Programme\\Internet Explorer\\iexplore.exe"
    and so I always get the error message. I guess the only
    solution to this problem is recompiling the code. It would
    be nice if one could controll the explorer_command variable
    for WinNT from within user.properties.

     
  • Christian Kremser

    Logged In: YES
    user_id=688001

    I was wondering about a similar problem for quite some time.
    I'm running WinNT and after clicking a hyperlink I always
    get the error: "Could not invoke browser." Finally I looked
    at the source and found in FreeMind.java, function
    openDocument, that there is a so called explorer_command
    variable which for WinNT, and thus also for Win2000, is set
    to "C:\\Program Files\\Internet Explorer\\iexplore.exe".
    That is the reason why in your case Internet Explorer is
    always launched. In my case the IE resides in a different
    directory "C:\\Programme\\Internet Explorer\\iexplore.exe"
    and so I always get the error message. I guess the only
    solution to this problem is recompiling the code. It would
    be nice if one could controll the explorer_command variable
    for WinNT from within user.properties.

     
  • Dennis Daniels

    Dennis Daniels - 2003-08-10

    Logged In: YES
    user_id=403318

    I've noticed same on linux. My default browser is Moz 1.4
    but when I invoke links Konqueror comes up! I don't use
    Konq. Very strange.

     
  • Christian Foltin

    • status: open --> closed
     
  • Christian Foltin

    Logged In: YES
    user_id=885594

    Solved using the user.properties file in version 0.7.1

     

Log in to post a comment.