for the background, ConfRoomInfo will basically contain (as the name suggests), the information about configuration room,
right now, it has the scenario, scenariomodus and the list<player>.
we were thinking it should have only the scenario_name, scenariomodus_name and player's title. we need not keep complete scenario and other stuffs in the update.
but right now scenario does not have any attribute such as name, so will it be proper to create a name inside scenario.
or is there any better way to do it.