FreeImage.dll not working under Win 2008 x64

d d
2010-09-08
2014-08-05
  • d d

    d d - 2010-09-08

    FreeImage.dll is not working under Win 2008 x64 with IIS7 when I use it from
    ASP.NET. I get this error:

    Unable to load DLL 'FreeImage': The specified module could not be found.
    (Exception from HRESULT: 0x8007007E)

    I downloaded source and recompiled for x64 successfully, and the error
    persists:

    Unable to load DLL 'FreeImage': The application has failed to start because
    its side-by-side configuration is incorrect. Please see the application event
    log or use the command-line sxstrace.exe tool for more detail. (Exception from
    HRESULT: 0x800736B1)

    Only from a console application I am able to use Freeimage.dll (32) on x64.

     
  • Carsten Klein

    Carsten Klein - 2010-09-09

    Hi,

    which version of the DLL are you using? Version 3.14.0 has some known similar
    problems with OpenMP support. Ensure not to use this version.

    Carsten

     
  • JackN

    JackN - 2012-07-24

    Any luck on this issue? We're experiencing the same issue and we've tried
    multiple settings within IIS with no success.

    • Enabled 32 bit applications.
    • Changed app pool to network service.
    • Loaded most recent version of binaries to server.
     
  • vbguyny

    vbguyny - 2013-04-12

    I am having the same issue. I did everything that JackN did plus copied the FreeImage.dll and .Net library to c:\Windows, c:\Windows\System32. Gave full permissions to the dll for the Everyone user. Also did a stack trace on the dump file. It reports that the error happens when it tries to invoke any of the extern API calls on the FreeImage.dll file.

    I have no issues running the same code on my dev. machine which is Windows XP Pro Sp3 and IIS 5.1. I also created a simple Windows app which works without any issues on the prod. server, so it appears to be something IIS 7 and Windows 2008 R2 x64.

     
    • Le Nhat Duy

      Le Nhat Duy - 2017-05-26

      It's solved my problem. I copy FreeImage.dll to C:\Windows and it's worked. You save my days. Thanks so much.

       
  • Maukka

    Maukka - 2014-07-02

    Solved the problem on Win7 x64 by coping the FreeImage.dll to C:\Windows folder and adding a FreeImage environmental variable that points to C:\Windows\FreeImage.dll. Any help on this?

     
  • Joeri

    Joeri - 2014-08-05

    Besides adding the FreeImageNET.dll wrapper to the project folder, I had to add the FreeImage.dll (c++) file to the project BIN directory. That solved it for me.

     

Log in to post a comment.