I'm running Mac OS X 10.6.8 Snow Leopard. I have a 32 bit program that is trying to use the 64bit dylib's generated by the homebrew installation tool. Obviously, it's failing. Is it possible to build 32bit dylibs and if so, how?

Kind regards,
Bruce.