T16-013 using met16 interface

Help
Anonymous
2007-03-08
2013-04-24
  • Anonymous - 2007-03-08

    I have a T16-013. I've been messing with it for the last couple months or so and haven't had any luck getting it to work. I tested it with my friends windows computer and their RPM test tool on their website, and it worked, so I know the device is fine now. I have a hex string I can test with the tech support gave me for a Ford ZX2 2002.
    The string is: 22 80 05 61 6A F1 01 0C 00 00 00 00 00 00 4E

    I changed INTERFACE_ADDRESS to 0x22 in diag_l0_me.c before I ran make.

    I tried the following:
    minicom -s
    set serial device to /dev/ttyS0
    minicom
    22 80 05 61 6A F1 01 0C 00 00 00 00 00 00 4E

    with no response. I was originally trying it with a usb->serial cable (with my laptop) which is how I'd prefer to do it, but lately I've been testing with a serial cable between the car and a desktop I've been setting up outside for testing runs (you should see the looks people give you when you have a computer sitting on a folding chair in the snow beside a car with a cable going to the car)

    I can post what it gave me inside scantool using:
    set interface met16
    scan

    next time I try, but I already closed the terminal I was using, and don't have the desktop out there anymore.

    Thankyou for any help,

    Sam

     
    • Anonymous - 2007-03-14

      ok, I got some output with serial interface now. This is what I did:
      ./scantool
      set interface met16
      set speed 19200
      scan
      monitor

      The problem is now I'm getting garbage:

      Press return to checkpoint then return to quit
      Parameter                      Current         FreezeFrame
      Fuel System Status             Open(rsvd)      -----         
      Calculated Load Value                          -----         
      Engine Coolant Temperature     -36F            -----         
      Short term fuel trim Bank 1                    -----         
      Long  term fuel trim Bank 1                    -----         
      Fuel Pressure                  39.2psig        -----         
      Engine RPM                                     -----         
      Vehicle Speed                   56mph          -----         
      Ignition timing advance Cyl #1                 -----         
      Intake Air Temperature         264F            -----         
      Air Flow Rate                    57.2lb/min    -----         
      Absolute Throttle Position                     -----         
      Bank 1 Sensor 1 Voltage/Trim   0.215V/-89.8%   -----         
      Bank 1 Sensor 2 Voltage/Trim   0.000V          -----         
      Requesting Mode 7 (Current cycle emission DTCs)...
      Request failed, retrying...
      Currently monitored DTCs: P0118 P0340 P1380
      Requesting Mode 1 Pid 0x03...
      Mode 1 Pid 0x03 request no-data (0)
      Requesting Mode 1 Pid 0x04...
      Mode 1 Pid 0x04 request no-data (0)
      Requesting Mode 1 Pid 0x05...
      Request failed, retrying...
      Requesting Mode 1 Pid 0x06...
      Requesting Mode 1 Pid 0x07...
      Requesting Mode 1 Pid 0x0a...
      Request failed, retrying...
      Requesting Mode 1 Pid 0x0c...
      Requesting Mode 1 Pid 0x0d...
      Requesting Mode 1 Pid 0x0e...
      Request failed, retrying...
      Requesting Mode 1 Pid 0x0f...
      Requesting Mode 1 Pid 0x10...
      Requesting Mode 1 Pid 0x11...
      Request failed, retrying...
      Requesting Mode 1 Pid 0x13...

      My car is idling when I do the monitor, and all values change at a random rate. Any suggestions?

      Sam

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks