no ECU connection with '95 Legacy and t16_003

Help
Derek E
2005-08-27
2013-04-24
  • Derek E

    Derek E - 2005-08-27

    I've got a '95 Subaru Legacy and a multiplex engineering t16_003. I'm having trouble getting the software to find the ECU. I'm using slackware 10.0 and linux 2.6.12.5. The computer is running off a 3 pronged grounded outlet. I've tried scanning with the car running and just in the ON position. I've also done the following:

    - set up the symbolic link from /dev/ttyS0 to /dev/obdII0 with  chmod 777. I even tried ttyS1 just in case it was that one.
    - set interface met16
    - debug all 0xffff
    - everything from root
    - renice scantool's pid to -20
    - dmesg reported ttyS0's rate was changed by software
    - even tried the other gentleman's commenting-out suggestion in http://sourceforge.net/forum/forum.php?thread_id=870264&forum_id=108777

    Here's the relevent log from scantool's debug after issuing the scan command:

    Trying ISO9141:
    diag_l2.c:346:  diag_l2_open MET16 subinterface 0 L1proto 1 called
    diag_l2.c:308:  diag_l2_closelink 0x8074528 called
    diag_l0_me.c:215:  link 0x8074b48 closing
    diag_l0_me.c:165:  open subinterface 0 protocol 1
    diag_tty.c:128:  Device /dev/obdII0 opened, fd 3
    diag_tty.c:263:  setup: device fd 3 dt 0x8074ca8 speed 19200 databits 8
    stopbits 1 parity 3
    diag_l0_me.c:843:  getflags link 0x8074b48 proto 1 flags 0x1
    diag_l2.c:439:  diag_l2_startCommunications dl0d 0x8074b48 L2proto 1
    type 0 baud 10400 target 0x33 src 0xf1 called
    diag_l2_iso9141.c:204:  diag_l2_iso9141_startcomms conn 0x807acc8
    diag_tty.c:263:  setup: device fd 3 dt 0x8074ca8 speed 19200 databits 8
    stopbits 1 parity 3
    diag_l2.c:707:  diag_l2_ioctl 0x807acc8 cmd 8705
    diag_l0_me.c:423:  device link 0x8074b48 info 0x8074c80 initbus type 2
    proto 1
    diag_l0_me.c:238:  device link 0x8074b48 sending to ME device: 0x38
    0x20 0x33 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x53
    diag_l2_iso9141.c:240:  diag_l2_iso9141_startcomms returns -1
    diag_l2.c:527:  protocol startcomms returned -1
    diag_l2.c:559:  diag_l2_StartComms returns (nil)
    diag_l2.c:412:  diag_l2_close 0x8074b48 called
    ISO9141 Failed
    **********************

    I have the rest if anyone wants it, but its quite verbose. Anyone have any ideas? Thanks in advance

     
    • Derek E

      Derek E - 2005-09-27

      Still haven't gotten it working, though more light has been shown. I've gotten freediag working with a 2001 Corolla and a 2000 Subaru Legacy, but it still doesn't work on my '95.

      1. Tried the 2.4 Kernel.

      2. Tried running from root and a low nice value

      3. Commented out scanning modes 5-9 as suggested above.

      The problem seems to be in the ecu wakeup sequence. Anyone have any success with '95 subarus? It seems to be the obdII standard wasn't fully finished when the car was made, which is probably why it won't work.

      Thanks in advance,
      Derek

       
    • Derek E

      Derek E - 2005-12-26

      I found out that only the automatic transmission of '95s work with obdII. Doh.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks