Trade with Europe

  • seddrik

    seddrik - 2014-05-17

    FreeCol 0.10.7
    Win 7

    Sent a ship with furs and wood. Reached Europe and got gold for it. I loaded the ship with 2 people and tried to send it back... and it goes in transit but never reaches my colony. It always returns to Europe. I change the trade route , I try many diff things, all with the same result.

    Any ideas what I am missing or is this a bug?

    I searched the pdf and the forums as much as I could but didnt see anything on this.


    Figured out a solution. Send it to Europe with a trade outré. Then clear the route and send it back. Weird but works.

    Enjoying the game. Reminds me so much of an old commodore 64 game I played and loved. : )

    Last edit: seddrik 2014-05-17
  • Lone_Wolf

    Lone_Wolf - 2014-05-18

    Is the trade route setup like this :

    start colony : furs & wood in carrier screen
    2nd stop : europe, carrier screen empty

    This executes as follows :
    goto start colony, load furs and wood.
    Once both goods are loaded, sail for europe
    in europe : unload goods and return to start colony
    the unloading takes place, but before the trade route is continued you manually load units and give the ship a separate order to go to the new world.

    It goes into transit.

    At this point the ship has 2 sets of orders :
    - the traderoute
    - your manual order to sail to a colony

    My guess is the trade route code detects the ship has cargo on board and so follows the trade route order : sail to europe, unload cargo .

    I wonder what will happen if you load units on carrier, but don't order it into transit.

    This does look like you found a conflict that occurs when player does change cargo/orders for a carrier executing a trade route.

    Imo it is a bug, but how to deal with this requires some discussion.

    seddrik, please send a message about this to freecol-developers mailing list.

  • Mike Pope

    Mike Pope - 2014-05-19

    My guess is that the trade route logic determined that there was no work to do and so it moved to the current stop in the route. However, setting a destination for a unit with a trade route is not supposed to work --- trade routes and destinations are mutually exclusive. That it is possible to do it in Europe is a bug. If you try it with a unit on the map, you will get the message:

    traderoute.reassignRoute=Your %unit% is assigned to trade route %route%. Setting its destination will drop it from the trade route. Are you sure you want to do this?

    I will fix the Europe panel to do the same.


Log in to post a comment.