Game reeeeeally slow

Help
Matt S
2009-05-11
2013-01-10
  • Matt S

    Matt S - 2009-05-11

    Sometimes when I click another part of the map it takes a really long time to move, like 10-30 minutes long. It's easily overwhelmed. I dare not click too quickly, because then I know it will slow down on me. This is especially cumbersome when I'm trying to give troops goto orders, or select troops from another part of the map. The whole game seems rather slow. I'm running .8.2 in ubuntu jj.

     
    • Matt S

      Matt S - 2009-05-11

      I figured out what was causing it to be slow. Even though I had the Java Runtime Environment from Sun installed, it was by default using OpenSDK's JRE. Once I removed OpenSDK, it began using the proper JRE and now it works great.

       
    • Michael Vehrs

      Michael Vehrs - 2009-05-11

      Still strange. I use OpenJDK on a regular basis and do not consider it to be any slower than Sun's JRE.

       
  • Mike Chelen

    Mike Chelen - 2010-02-01

    Same problem, though the delay times were more like 3-5 seconds, on a 2ghz Athlon. Uninstalled all the openjdk and icedtea packages, now FreeCol is much, much faster!

     
  • Mike Pope

    Mike Pope - 2010-02-01

    I had some slowdowns until I experimented with the 2d settings.  -Dsun.java2d.pmoffscreen=false worked for me.

     
  • Richard Abbott

    Richard Abbott - 2010-07-17

    THANK YOU kalleyphona.

    Removing the OpenJDK packages made this game playable.  I was experiencing 3-5second delays for EVERY piece slide.  Now its instantaneous.

     
  • Camaro95

    Camaro95 - 2010-08-09

    What is OpenJDK? How does one remove it? How does one change the 2d settings?

     
  • Iynx

    Iynx - 2010-08-22

    You can change the 2d settings by editing the freecol startup script. On my linux box, this was /usr/bin/freecol.
    I changed the line

    java -Xmx256M  -jar $FC_PATH/FreeCol.jar "$@" -freecol-data $FC_PATH/data

    to read

    java -Xmx256M -Dsun.java2d.pmoffscreen=false -jar $FC_PATH/FreeCol.jar "$@" -freecol-data $FC_PATH/data \

    now freecol is fast :)  Thanks mpope.  

     
  • Iynx

    Iynx - 2010-08-22

    The "-Dsun.java2d.pmoffscreen=false" option works with both OpenJDK and Sun Java, I tried both.

     
  • stefan_jones

    stefan_jones - 2010-09-16

    Thanks for this thread! I was about to give up on .9.4.

    Can this information be added to the README? It might eliminate a lot of frustration.

     
  • Maju

    Maju - 2010-09-27

    I had the same problem as Kallephonya and followed his/her trick. It works but after some time (one hour?)  playing I have to save and restart the game anyhow because it begins lagging anyhow. AMD Athlon 64.

     
  • Michael Vehrs

    Michael Vehrs - 2010-09-28

    Should we add this option to the startup script, or would that impact machines that don't have the problem in the first place?

     
  • Joseph Springer

    Joseph Springer - 2010-09-28

    PLEASE add it b/c some enthusiasts have no Earthly idea what you are talking about.  Seriously, I'm no computer dummy but that is a little out of my comfort zone…

     
  • Michael Vehrs

    Michael Vehrs - 2010-09-29

    That doesn't answer my question. Does the switch have a negative impact on machines that are not suffering from graphics problems in the first place?

     
  • Lone_Wolf

    Lone_Wolf - 2010-11-16

    Basically this setting is valid fpor *nix systems only and determines where java stores images (in pixmaps or in DGA , a framebuffer).
    -Dsun.java2d.pmoffscreen=false makes jave use DGA .

    (see http://download.oracle.com/javase/1.5.0/docs/guide/2d/flags.html#pmoffscreen )

    This is essentially a driver problem, and may not be present with all card/driver combos.

    I use a Radeon 4870 with the open source drivers and also have this problem.

     
  • Maju

    Maju - 2010-11-16

    It started working ok for me with the latest release. Still some minor bugs but this crucial aspect seems solved: now you can play until you get bored.

     
  • Michael Vehrs

    Michael Vehrs - 2010-11-17

    @lone_wolfsf : Thanks for the information. I guess the option should not be used by default, but should be added to the FAQ.

     
  • Matias Griese

    Matias Griese - 2010-11-22

    Same issue and fix with integrated Intel graphics (H55, Ubuntu 10.04).

     
  • Jeff Nelson

    Jeff Nelson - 2012-03-02

    I'm running Linux Mint 11. To fix the issue, I edited the line in /usr/games/freecol that starts with

    run_java
    

    to read:

    run_java $disablenet -Xincgc -Xmx180M -Dsun.java2d.pmoffscreen=false net.sf.freecol.FreeCol --freecol-data /usr/share/games/freecol $lang_argument "$@"
    
     
  • Mike Pope

    Mike Pope - 2012-03-02

    The pmoffscreen part is likely to be what is making the difference here.  For reference, this is now controllable in-game through the "Use Pixmaps" option.

     
  • Pete Sherwood

    Pete Sherwood - 2012-05-29

    I tried the "Use Pixmaps" toggle on/off with no change in the slowness. Then I simply changed the /usr/local/freecol/freecol script from:

    java -Xmx512M -jar FreeCol.jar $1 $2 $3 $4 $5 $6 $7 $8 $9

    to

    java -Xmx512M -Dsun.java2d.pmoffscreen=false -jar FreeCol.jar $1 $2 $3 $4 $5 $6 $7 $8 $9

    and problem solved!

    Perhaps adding a second script /usr/local/freecol/freecol.nix and suggesting in the README file users try this second script if they experience slowness to the game, would be useful.

    Simple solution and then others would not have to find this Forum in order to find the solution.

    I did notice in my 9.5 installation that this was already done so this is not the first time the *nix users have had this problem.

     
  • Pete Sherwood

    Pete Sherwood - 2012-05-29

    PS: I'm running Red Hat's Fedora Linux

     
  • Mike Pope

    Mike Pope - 2012-05-29

    Did you quit the game and restart after toggling the pixmaps option?  I now suspect that is necessary for it to work.

    BTW since, like myself you are a Fedora user, what graphics driver are you using?  I am no longer able to reproduce this bug on F16 with the radeon driver.

     

Log in to post a comment.