#7849 migrating wiki to Allura as requested

self-service
https://sourceforge.net/projects/sonia/
sonia
2015-03-06
2014-06-06
No

Dear SF,

I'm trying to migrate my project's wiki as requested following the instructions in the email I received:
http://sourceforge.net/p/forge/documentation/SourceForge%20MediaWiki%20Importer/

I get an error message 'Mount point "wiki" is already in use', presumeably because my existing wiki is at that address? Is it possible to adjust the mount point after import? Can I import it to 'newwiki', re-create the tables that exist in the old wiki, and then delete the old wiki and change 'newwiki' to 'wiki' so that existing external urls will still work?

thanks

Discussion

  • Anonymous - 2014-06-09
    • status: unread --> pending
    • assigned_to: Chris Tsai
     
  • Anonymous - 2014-06-09

    It's the default Allura wiki that's at that address. Currently, that appears to just have the default content. You can remove that to make room for the new wiki import via Admin -> Tools.

    Alternatively, you can import to a different mount point/location, however it's not possible to change the mount point after the fact.

    Regards,
    Chris Tsai, SourceForge.net Support

     
  • Skye Bender-deMoll

    Thanks, Using the advice above, I was able to migrate the wiki structure. However, in addition to clobbering the tables (as documented) the import also failed to bring in any of the images. Is it possible to update the import script to that it will copy in the images? I'd rather not have to re-upload all of these images, as was necessary during the last wiki migration.

    Also, will it be possible to symlink the apps/mediaWiki/sonia urls to /p/sonia/wiki/ so that all of incoming external links to the documentation will not be broken?

    thanks,
    -skye

     
  • Anonymous - 2014-06-18

    Looking at your wiki, we've determined that in the source of your wiki page, there's an additional LRM character at the end of the filename. To fix this, you will need to remove that extra character, as it's causing the image URL to be malformed.

    I found I was able to do this by just putting my cursor at the end of the filename, and hitting the "delete" key. The cursor won't move, and won't visibly do anything, but it'll remove that extra character.

    Let me know if this helps!

    Regards,
    Chris Tsai, SourceForge.net Support

     
  • Skye Bender-deMoll

    I deleted the LRM character at the end of the image links on the first page, and spend a good chunck of time trying to edit all the image links in the wiki. None of the other images seemed to have the issue. When I re did the import, the images on the first page worked, but all of the other images were lost. I'd paste links to illustrate the difference, but the mediaWiki link seems to be no longer working, was it already removed?

     
    • Anonymous - 2014-06-19

      Can you provide some example links for other pages you're seeing problems with? I only examined your main page for issues. It could be a different problem in those cases.

      And yes, the decommission is currently underway, as today is in fact the scheduled and announced date for that.

       
  • Anonymous - 2014-06-19

    To be clear, all the images were actually migrated and you can see them in the attachment lists for each of the pages, the problem is solely with incorrect translation of the syntax used (as you note, the alignment wasn't accounted for).

    Hence, you just need to correct the syntax, you don't need to re-upload.

    eg. on https://sourceforge.net/p/sonia/wiki/Installing_SoNIA/

    Instead of: [center](Image:Installerscreenshot.jpg)
    you'll want: [[img src=Installerscreenshot.jpg]]
    Note, aligning "middle" doesn't seem to work, but adding the option "align=right", if so desired, does.

     
  • Anonymous - 2014-06-26
    • status: pending --> self-service
     
  • Anonymous - 2014-06-27
    • labels: --> siteops, so-55390
    • status: self-service --> assigned
     
  • Anonymous - 2014-06-27

    I've put in a request for this with our team.

    Regards,
    Chris Tsai, SourceForge.net Support

     
  • Anonymous - 2014-07-01
    • status: assigned --> fixed
     
  • Anonymous - 2014-07-01

    This redirect is now in place.

    Regards,
    Chris Tsai, SourceForge.net Support

     
  • Anonymous - 2014-07-01

    It seems we didn't test this enough. I've re-opened this with our team.

    Regards,
    Chris Tsai, SourceForge.net Support

     
  • Anonymous - 2014-07-01
    • status: fixed --> assigned
     
  • Zangune

    Zangune - 2015-01-16

    Hi Skye Bender-deMoll, this link

    http://sourceforge.net/apps/mediawiki/sonia
    


    now points here

    https://sourceforge.net/p/sonia/wiki
    


    but other links always redirects to the new main wiki page.
    Do you still need that?

     
  • John Barrett

    John Barrett - 2015-03-06
    • status: assigned --> self-service
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks