#6712 Problems with login on page and reading/posting in discussion forums

self-service
None
2014-02-12
2014-02-09
elwood151
No

Problems with login on sourceforge.net, especially in forums like https://sourceforge.net/apps/phpbb/freeplane

For example, I just tried to post an answer in a thread, after submitting, I only get an empty browser window with this URL https://sourceforge.net/apps/phpbb/freeplane/posting.php?mode=reply&f=1&sid=b6f09bc41e5a427b2a201ba7ded3a407&t=882 and nothing happens, no error message, but also no answer in the thread!

I also observed that sourceforge often forgets my login data (although I always check the "remember login" checkbox), I sometimes am lead to the login page several times a day when trying to post an answer etc.

I'm using Safari 5.1.10 on MacOS X 10.6.8 .

This is really annoying and makes using sourceforge an absolute pain, unfortunately!!

I suppose that others have this problem too, but I could not find any FAQ information about that.

p.s. even after trying to save this ticket, I got an error message and was lead to the login page of sourceforge again (seeing a pop up window about cookies...)

I'll try to save again now...

Discussion

  • elwood151

    elwood151 - 2014-02-09

    p.s. this happened again, I can not post in this thread:
    https://sourceforge.net/apps/phpbb/freeplane/posting.php?mode=reply&f=1&sid=6167b7ec4c7be0b2793797b060139073&t=882

    (Some minutes before, I successfully posted another answer in another thread in the same discussion forum...)+

    Sometimes it happens, that in the address bar of the browser, the URL constantly changes from http:// to https:// and back (the rest of the url stays the same).

     
    Last edit: elwood151 2014-02-09
  • Anonymous - 2014-02-11
    • status: unread --> self-service
    • assigned_to: Chris Tsai
     
  • Anonymous - 2014-02-11

    Greetings,

    I suspect that this is due to issues with the way the classic authentication system is integrated with the Allura platform. We have work planned to do a full re-write of our login/authentication system, and I expect this issue be resolved at this time.

    Until then, I recommend not trying to preserve your login session (ie., don't check the "Remember Me" box), and go to the login page first, before trying to write to any tickets.

    Also, I personally find the "Lazarus" browser plugin to be very useful in situations like this where you might otherwise lose data you inputted: http://getlazarus.com/

    That said, if you're on Firefox, I've had trouble with Lazarus 3 as available from their site, but Lazarus 2.3 has worked well for me for a very long time. It's still available here: https://addons.mozilla.org/en-US/firefox/addon/lazarus-form-recovery/

    Regards,
    Chris Tsai, SourceForge.net Support

     
  • elwood151

    elwood151 - 2014-02-12

    Hi Chris,
    thanks for your answer!
    So that means, that I have to pass the login page each time (even several times a day) before I want to write something in sourceforge.net forums or even view a new post in a forum?
    This is really very annoying. :-(

    Is there already a planned date for the rewritten login/authentication system?
    Are there any other things that I might try?
    Does every sourceforge.net-user has those problems, or do my problems have something to do with my software setup (browser, OS, ...)?
    elwood151

     
    Last edit: elwood151 2014-02-12

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks