#889 window position shifts after resolution changes

v1.3.5
closed-wont-fix
nobody
5
2013-02-13
2008-09-27
BH
No

When changing X resolution, the position of windows on all workspaces shift. In my use, all windows shift toward the top left. Simple test case:

xrandr -s 640x480; xrandr -s 1600x1200

Not sure of the exact fluxbox version where this change occured, but it is likely fairly recent. I noticed the problem when my screen was restored after playing a full screen dosbox game, which I hadn't played in a few months.

Arch Linux, x86-64
fluxbox 1.1.1-1
xorg-server-utils 7.3-1 (xrandr)

Discussion

  • Mark Tiefenbruck

    Actually, fluxbox doesn't do that, except for the focused window if it's completely off the screen. Your windows detect that the resolution changes and ask to be moved. If you don't actually want to view your desktop at 640x480, don't set that resolution. Run your game in a separate X server.

     
  • Mark Tiefenbruck

    • status: open --> closed-wont-fix
     
  • BH

    BH - 2008-09-27
    • status: closed-wont-fix --> open-wont-fix
     
  • BH

    BH - 2008-09-27

    Sorry, I disagree. This worked fine before with fluxbox (staring dosbox fullscreen and restoring on exit), and I consider it to be a bug, or at least a regression.

    Maybe something changed with the save/restore of window positions? I have Remember->Position and ->Dimensions selected, so shouldn't they be restored properly?

     
  • BH

    BH - 2008-09-27

    Sorry, I disagree. This worked fine before with fluxbox (staring dosbox fullscreen and restoring on exit), and I consider it to be a bug, or at least a regression.

    Maybe something changed with the save/restore of window positions? I have Remember->Position and ->Dimensions selected, so shouldn't they be restored properly?

     
  • Mark Tiefenbruck

    Well, it turns out you're half right. It did change, but it's not a regression. It was added for the case when somebody removes a monitor, but I stand by the change in general: it is expected behavior that your windows should be moved to fit in the screen when you decrease the resolution. Perhaps the placement algorithm could be improved, but the old behavior will not be restored. If you don't want to view your desktop at 640x480, don't change the resolution. Run the program in another X server.

     
  • Mark Tiefenbruck

    • status: open-wont-fix --> closed-wont-fix
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks