#861 Maximized Windows Don't Up Full Screen Width

closed-out-of-date
nobody
None
5
2010-05-07
2008-04-15
Eric Siegel
No

I am running fluxbox 1.0.0 on openSUSE 10.3 (downloaded from repositories). When I maximize a window it doesn't fill up the whole screen. It fills the whole screen vertically, but not horizontially. I don't have the slit visible, so I don't think that's the problem. How do I make windows maximize to the full window width and height (minus the taskbar)?

Discussion

  • Mark Tiefenbruck

    • status: open --> pending
     
  • Mark Tiefenbruck

    Logged In: YES
    user_id=1538990
    Originator: NO

    It could be several things. If your window resizes in increments (e.g. a terminal or some text editors), we don't override that. There's a setting in the git version to override it. It could also be a bug with the slit, even though it's invisible. If there's something in your slitlist file, it might still take up a few pixels for no good reason. That's also fixed in git.

    I might have forgotten one. Anyway, try the git version of fluxbox. If it still doesn't work, then we can investigate further.

     
  • Eric Siegel

    Eric Siegel - 2008-04-15
    • status: pending --> open
     
  • Eric Siegel

    Eric Siegel - 2008-04-15

    Logged In: YES
    user_id=2064131
    Originator: YES

    Thing is, this happens for ALL windows. I do have tilda running, would that cause this error?

     
  • Mark Tiefenbruck

    Logged In: YES
    user_id=1538990
    Originator: NO

    I don't think so, but you never know. Look at the output of `xprop -root _NET_WORKAREA' and `xprop -root _NET_DESKTOP_GEOMETRY'. The first one gives the geometry (x,y,width,height) of each workspace, which is how we place maximized windows. The second gives the screen size. You should be able to figure out from these two whether or not the extra area has been reserved. To determine whether or not the slit is the problem, change the slit's position and check the work area again.

     
  • Eric Siegel

    Eric Siegel - 2008-04-17

    Logged In: YES
    user_id=2064131
    Originator: YES

    $ xprop -root _NET_WORKAREA
    _NET_WORKAREA(CARDINAL) = 0, 0, 1280, 800, 0, 0, 1280, 800, 0, 0, 1280, 800, 0, 0, 1280, 800
    $ xprop -root _NET_DESKTOP_GEOMETRY
    _NET_DESKTOP_GEOMETRY(CARDINAL) = 1280, 800

    I can't see anything wrong with those variables. Moving the slit doesn't help either.

     
  • Eric Siegel

    Eric Siegel - 2008-05-13

    Logged In: YES
    user_id=2064131
    Originator: YES

    Any thing else I can try. Or any other fixes available?

     
  • Mark Tiefenbruck

    Logged In: YES
    user_id=1538990
    Originator: NO

    You're going to have to install the git version in order to investigate this further.

     
  • Eric Siegel

    Eric Siegel - 2008-05-14

    Logged In: YES
    user_id=2064131
    Originator: YES

    Ok, I have the git version of fluxbox, and this error is still present.

     
  • Nobody/Anonymous

    Logged In: NO

    Same issue was catched with Thunderbird. I don't know whats wrong, but you can try to reproduce it by next way:
    - run thunderbird
    - try to resize thunderbird window by moving fluxbox size border - seems no error
    - try to resize thunderbird window by moving thunderbird size border (it is looks like in other GTK applications) - wrong geometry; thunderbird resized but old area still the same and we can see ugly repainting

    Tested with blackbox, kwin and metacity - no issue was present.

     
  • Eric Siegel

    Eric Siegel - 2008-05-31

    Logged In: YES
    user_id=2064131
    Originator: YES

    No, the problem is that in fluxbox all windows do not maximize to the full screen width. In KDE, all windows maximize just fine.

     
  • Nobody/Anonymous

    If the gap is on one side only (the side where the slit is located), you might try (if you haven't already):

    Fluxbox Menu -> Configure -> Slit -> Maximize Over

    I haven't used fluxbox 1.0.0 for some time, but it used to be that you had to turn that setting on to make a maximized window take up the whole screen. Without that setting, the slit would reserve a few pixels.

     
  • Mathias Gumz

    Mathias Gumz - 2010-05-07

    whats the status of this bug?

     
  • Mathias Gumz

    Mathias Gumz - 2010-05-07
    • status: open --> pending
     
  • Eric Siegel

    Eric Siegel - 2010-05-07

    I haven't used openSUSE for a while now. I currently use Arch Linux, and Fluxbox behaves correctly. So, I guess this bug can be closed.

     
  • Eric Siegel

    Eric Siegel - 2010-05-07
    • status: pending --> open
     
  • Eric Siegel

    Eric Siegel - 2010-05-07
    • status: open --> closed
     
  • Eric Siegel

    Eric Siegel - 2010-05-07
    • status: closed --> closed-out-of-date
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks