Cannot download from MLR

  • Nobody/Anonymous


    FT is trying to read the files from my MLR SP24 XC FreeFlying but dont get anything. It searches and searches without stopping, also after about 1 minute the "stop" and all other buttons dont work anymore. Then I have to restart FT. Perhaps it is a USB-Serial cable problem, but I dont think so because when I set another format than NMEA output I get an error-message from FT within 2 seconds.
    Also I tried reading the tracks from the same MLR with a Windows PC and the "MaxPunkte" program without any problems.

    Im using OS X 10.3.9 and a USB-Serial Cable with Prolific Chip and have installed the latest firmware from Prolific. My MLR Settings are NMEA 2.0 output.

    Which "NMEA Format" Settings do you have in your MLRs????
    There are so many different to choose...

    Greetings from Germany and sorry for my bad english!!!

    • Nobody/Anonymous

      This is exactly the same behavior I experience using my Garmin 196 running version 4.1 of it's software and a Keyspan USA-28X USB-Serial adapter with a 15" TiBook running 10.3.9. Earlier versions of my 196 software worked fine, but I can't go back or I'd lose features important to flight. I have found that GPSBabel will download from my 196 just fine, but FT only recognizes the first track in a multi-track GPX XML file. :-( So I currently I'm manually extracting each track from the GPSBabel track file, a bit of a pain.

      Gauthier - is there a way to record the serial port dialog going on with these units that will  help diagnose the problem?


      P.S. I wrote Garmin tech support about this and they 'don't support anything Mac.' Downloads do still work with Garmin's FlightBook and MapSource software run on VirtualPC 7.

      • Gautier Taravella

        Unfortunately, there isn't really possibility to see what going on between FT and a Garmin GPS on the serial port in a profitable way. FT uses an old free software for Garmin GPS and it does not really surprises me if it doesn't work for newest units. I'll try to improve this by switching to another solution but in the mean time I think the best way around is to use another application.

        Concerning the GPS multi-track issue, could you add it in the RFE page above so that I can correct this ?

    • Gautier Taravella

      Hi, I don't have a MLR. Yet, when I added support for this device a friend lent me one and it worked. I don't remebeer the exact settings on the MLR but I assume that if you use the same one that work when using a PC it should work.

      Could you send me a log of what is written in the console (launch Application/Utilities/Console) when you try to transfer using FT ?

    • Nobody/Anonymous

      Hi all,

      J'ai le meme comportement.

      Le matriel :
      Powerbook 17" OSX 10.3.9
      FT 0.0.17
      MLR 24XC vol libre
      Adaptateur DB9-USB Hewlett-Packard
      Protocole NMEA-183-2.0

      Lorsque je demande la rcupration de donnes, le menu "serial port" de FT ne me propose que "Bluetooth-PDA-sync".

      Aprs quelques secondes de recherche, FT me rend un message d'erreur du type "time out while waiting data - check connection".

      La console rapporte :

      Invalid Line 3: DefaultSavePath    =
      2005-06-14 21:26:33.233 FlightTrack[6600] Using pixel format: <NSOpenGLPixelFormat: 0x1a82f50>
      2005-06-14 21:26:33.634 FlightTrack[6600] Initializing open GL context
      OpenGL error 0x501
      2005-06-14 21:26:44.025 FlightTrack[6600] DL TRKS
      Jun 14 21:26:44 zebre last message repeated 8 times

      Short translation : I experiment the same behaviour with my MLR FreeFlight : no detection while trying to download data.

      • Gautier Taravella

        You have to make sure you follow these instructions:

        The GPS shall have the serial port activated (in the serial port menu) and be in NMEA mode.
        The speed setting in FlightTrack shall be 19200 or 38400 bps.

        I know that 0.0.17 is working with MLR with MacOS 10.3.9. If it still does not work, it might be a problem with the cable or the serial adapter.

    • 75rz

      75rz - 2005-06-14

      Sure I checked the speed rate, and the serial activation on the MLR (the phone icon is flashing).

      The point is that the FT menu only displays "Bluetooth-PDA-sync". I suspect the cable not to function properly (but the cable and the DB9-USB adptator are new...)

      Maybe you could point me a way to test the connection from a terminal, Gautier ?


    • 75rz

      75rz - 2005-06-15

      OK folks, sorry but I'll switch to french for clarity, I'll make a resume at the end.


      Salut Gautier,

      Je viens de tester mon MLR sur une machine Linux avec mes cables, et tout marche bien (avec minicom je reois les donnes de position en temps rel depuis le GPS).
      Ceci valide donc le fonctionnement de la chane de connection.

      Il me semble donc que le problme sur mon powerbook 17" viens du fait que FT ne dtecte pas que le GPS est connect via un cable USB (d'o le fait que je n'ai que "Bluetooth-PDA-sync" dans le menu "serial port").

      Donc, comment que je dois faire ?   ;->

      for our non-french speaking folks :
      I checked the connectivity on a linux machine, and I managed to receive data from the GPS.
      So, I suspect that the problem is somewhere in the way FT search connected devices through USB port on my powerbook.


      • Gautier Taravella

        FT ne dtecte pas automatiquement un GPS, FT obtient toute la liste des ports srie du systme et les prsente  l'utilisateur pour qu'il choisisse le bon.

        Si tu ne vois dans le menu des ports srie que 'Bluetooth-PDA-Sync' que ton adaptateur srie-usb soit branch ou non, cela signifie sans ambiguit que cet adaptateur n'est pas reconnu par le mac.

        Il faut quitter et dmarrer FlightTrack aprs avoir branch l'adaptateur.

        As-tu install les drivers pour cet adaptateur ? A ma connaissance, il n'y a pas d'adaptateur srie qui marche en plug'n play.

    • 75rz

      75rz - 2005-06-15


      J'ai juste achet le cable, et rien n'tait fourni avec...
      C'est un produit HP (du moins, le logo HP est grav sur la prise DB9). Je vais voir chez eux s'il y  quelque chose qui trane.

      Eric Pelletier

    • 75rz

      75rz - 2005-06-20

      Merci Linux :-)

      J'ai russi  attraper dans les log le type de chip qui quipe mon adaptateur USB-srie (un FTDI), et j'ai trouv sur le site du fabriquant le driver qui va bien. Hop !, les donnes sont transfres dans mon powerbook ;-)


      Eric Pelletier

    • Nobody/Anonymous

      moi aussi je galere :
      j'ai install le driver pour mon cable usb/serie et branch mon MLR sp 24 xc vl, mais rien ne se passe quand je lance le telechargement de la trace, j'attends , j'attends .... encore


      • 75rz

        75rz - 2005-07-06

        Va faire un tour dans les prfrences systme / rseau / configuration des ports rseau. Tu devrais voir apparatre l ujne entre correspondant  ton driver Srie-USB.
        Ensuite, lorsque tu va dans FT, choisi ce port dans la liste des ports pour l'importation.

        Tiens-nous au courant...

        Eric Pelletier

    • papilou

      papilou - 2005-07-08

      j'tais prt  vous dire que la reconnaissance de port tait automatique avec Os 10.3, car mon adaptateur USB-srie avait t reconnu sans que j'aie conscience d'avoir entr quelque donne que ce soit ... mais le changement de partition disque (test de 10.3.8 au lieu de 10.3.7) me prive de cette connexion : FT ne trouve plus de port srie (MacGPSPro non plus)... et pourtant l'adptateur USB-srie est bien dtect sur l'arbre USB
      Je cherche ...

      • Gautier Taravella

        Le fait de voir apparaitre l'adaptateur dans l'arbre des periphriques USB (dans les infos systmes) ne signifie pas grand chose. Cela veut juste dire que le systme a bien dtct qu'un priphrique a t branch.

        Pour popuvoir exploiter ce priphrique (dans notre cas, avoir un port srie reconnu par le systme), il faut installer un driver.

        A ma connaissance, OS X n'est livr avec aucun driver usb->srie intgr.


Log in to post a comment.