Ok, i will try with depends.exe,

 

Thank you for the reply J !

 

Cordialy

 

David ingels

 

-----Message d'origine-----
De : Frederic Bouvier [mailto:fredfgfs01@free.fr]
Envoyé : mardi 27 avril 2010 11:10
À : FlightGear developers discussions
Objet : Re: [Flightgear-devel] can't launch flghtgear when openscenegraph iscompiled in release

 

----- "Alan Teeder" a écrit :
>

>

> From: Ingels David

Sent: Tuesday, April 27, 2010 12:18 AM

To: flightgear-devel@lists.sourceforge.net

Subject: [Flightgear-devel] can't launch flghtgear when openscenegraph iscompiled in release


>

>

I can't launch flghtgear when openscenegraph is compiled in release there is a bug with the linking  to zlib.dll

 

I dont understand why

 

Error is

 

‘Ordinal 55 not found on zlib.dll’

 

it seems to be a linking problem with zlib.dll

 

Its only when i compil openscenegraph on other version than debug (release ect...)

 

Help !

 

David ingels

I also had zlib.dll problems. These went away when I re-ordered my PATH environment to ensure that the version of zlib.dll that I wanted was nearer the top. Many programs install their own version of zlib.

 

Depends.exe is the tool you need to find out which dll´´s fgfs (or any other progarm) will actually load at run-time. http://www.dependencywalker.com/ (it is free and recommended by Microsoft at http://technet.microsoft.com/en-us/library/cc738370%28WS.10%29.aspx)

 


It only happens in release mode because the debug build link to zlibd.lib/dll and it is most likely that the only one in the system is the one located in the 3rdparty directory.
zlib.dll and other Open Source libraries are often used even by commercial products and there should be one with a different version elsewhere, possibly in c:\windows\system32

-Fred


--
Frédéric Bouvier
http://my.fotolia.com/frfoto/              Photo gallery - album photo
http://www.youtube.com/user/fgfred64       Videos