Hi guys,

I've been trying to install flightgear on an fc5 box so that I can do some development but plib does not compile. It gives the following error:

Making all in ssgAux
make[2]: Entering directory `/root/plib- 1.8.4/src/ssgAux'
if g++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"plib\" -DVERSION=\" 1.8.4\" -DHAVE_LIBPTHREAD=1 -DHAVE_LIBGL=1 -DHAVE_LIBDL=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1  -I. -I. -I../../src/sg -I../../src/ssg -I../../src/util    -g -O2 -Wall -MT ssgaCelestialBody.o -MD -MP -MF ".deps/ssgaCelestialBody.Tpo" -c -o ssgaCelestialBody.o ssgaCelestialBody.cxx; \
        then mv -f ".deps/ssgaCelestialBody.Tpo" ".deps/ssgaCelestialBody.Po"; else rm -f ".deps/ssgaCelestialBody.Tpo"; exit 1; fi
ssgaSky.h:107: error: extra qualification 'ssgaCelestialBodyList::' on member 'ssgaCelestialBodyList'
ssgaSky.h:195: error: extra qualification 'ssgaCloudLayerList::' on member 'ssgaCloudLayerList'
make[2]: *** [ ssgaCelestialBody.o] Error 1
make[2]: Leaving directory `/root/plib-1.8.4/src/ssgAux'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/plib-1.8.4/src'
make: *** [all-recursive] Error 1


Any ideas for a solution?

Nick