On Saturday 27 June 2009 22:41:36 Vivian Meazza wrote:

> I haven't built using Cygwin for a while now. I migrated to MSVC9 because,

> while FG built OK, OSG wouldn't build with the then current version of gcc

> included in Cygwin. I'm not sure if that situation still pertains.

>

FWIW, I've been to keep FlightGear and SimGear cygwin compatible until up to about a year ago. I don't even know wether I ever tried to build OSG. Except for OSG, maintaining flightgear / simgear cygwin compatibility isn't that hard; however the main reason for giving this a very low priority is that the resulting code is just horribly slow, compared to a native build. Combined with the fact that my only usable windows machine is from the stone age (2003), this doesn't really help in running flightgear.

For the sake of uncovering bugs, etc, it would be nice to maintain cygwin compatibility, but for all practical reasons, I would go with Vivian's suggestion.

Cheers,

Durk