#97 FLAC__STREAM_DECODER_UNPARSEABLE_STREAM

1.3.0
wont-fix
None
5
2015-10-04
2007-12-16
thefarmer
No

When decoding a flac file I get an error message. The message ask me to check the version of the encoder used and it turns out to be an older version (1.1.0) than the decoder I'm using (1.1.2). I can't tell if the file is corrupt, so here it is for someone to check if it's a bug. The file is attached.

Any follow-up questions on this matter can be sent to me at stefanjohansson100( at)yahoo.com.

CD2Track02.flac: 16% complete

CD2Track02.flac: ERROR while decoding data
state = FLAC__STREAM_DECODER_UNPARSEABLE_STREAM

The FLAC stream may have been created by a more advanced encoder. Try
metaflac --show-vendor-tag CD2Track02.flac
If the version number is greater than 1.1.2, this decoder is probably
not able to decode the file. If the version number is not, the file
may be corrupted, or you may have found a bug. In this case please
submit a bug report to
http://sourceforge.net/bugs/?func=addbug&group_id=13478
Make sure to include an email contact in the comment and/or use the
"Monitor" feature to monitor the bug status.

Discussion

  • Josh Coalson

    Josh Coalson - 2007-12-16
    • labels: 105792 -->
    • assigned_to: nobody --> jcoalson
     
  • Josh Coalson

    Josh Coalson - 2007-12-16

    Logged In: YES
    user_id=78173
    Originator: NO

    can't tell without seeing the file.

    probably not a bug, moving to support requests.

     
  • thefarmer

    thefarmer - 2007-12-17

    Logged In: YES
    user_id=1961268
    Originator: YES

    Can't seem to upload the file. It's a big one (113 Mb). Could that be a problem?

     
  • thefarmer

    thefarmer - 2007-12-19

    Logged In: YES
    user_id=1961268
    Originator: YES

    Would it help to use the same version that was used when encoding? How can I get hold of version 1.1.0?

     
  • Josh Coalson

    Josh Coalson - 2008-01-11

    Logged In: YES
    user_id=78173
    Originator: NO

    if you can host the original file somewhere like megaupload.com or rapidshare that would be best. any file that exhibits the problem will suffice, regardless of encoder.

    most likely though the file was corrupted at some point.

     
  • Erik

    Erik - 2015-10-04

    Old out-of-date issue.

     
  • Erik

    Erik - 2015-10-04
    • status: open --> wont-fix
    • Group: --> 1.3.0
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks