#226 flac adds lots of seekpoints when encoding from stdin

closed
7
2006-11-13
2006-08-12
Anonymous
No

Win32 flac encoder adds seek points when it encodes
from stdin, for details see http://
www.hydrogenaudio.org/forums/index.php?showtopic=41287

Egor

Discussion

  • Josh Coalson

    Josh Coalson - 2006-09-01
    • assigned_to: nobody --> jcoalson
    • status: open --> open-accepted
     
  • Josh Coalson

    Josh Coalson - 2006-11-11
    • priority: 5 --> 7
    • status: open-accepted --> closed-accepted
     
  • Josh Coalson

    Josh Coalson - 2006-11-11

    Logged In: YES
    user_id=78173

    I need one of these truncated WAV files to see what the
    header looks like in order to fix this.

     
  • Nobody/Anonymous

    Logged In: NO

    I've sent you a sample by email.

    Egor

     
  • Josh Coalson

    Josh Coalson - 2006-11-13

    input file with bad chunk sizes

     
  • Josh Coalson

    Josh Coalson - 2006-11-13

    compressed by flac-1.1.3-beta2

     
  • Josh Coalson

    Josh Coalson - 2006-11-13

    logfile of compression

     
  • Josh Coalson

    Josh Coalson - 2006-11-13

    Logged In: YES
    user_id=78173

    the problem is that the wav file has incorrect chunk lengths.

    I actually do not know how to fix this, or even if it should
    be fixed, flac would have to notice that the chunk lengths
    are longer than the actual data and then assume for the user
    that they're ok with that, then wait till it gets to the end
    of the file before doing a bunch of things that it normally
    has to do up front.

     
  • Josh Coalson

    Josh Coalson - 2006-11-13
    • status: closed-accepted --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks