error with xrandr (lifebook 4215, mint linux)

Help
2010-08-27
2013-05-08
  • Nobody/Anonymous

    Hi, as a complete linux-newbie, I need some help with getting my fujitsu-buttons (on a lifebook t4215) to work.

    I've downloaded the package (fjbtndrv-2.1.3.tar.gz) and run the ./configure command.  And then it ends with this error:

    checking for XRANDR… configure: error: Package requirements (x11 xrandr) were not met:

    No package 'x11' found
    No package 'xrandr' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables XRANDR_CFLAGS
    and XRANDR_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    What does it all mean? What and where is that x11 and xrandr ? What do I need to do now?

    (if it would matter: the linux distro i'm using is Linux Mint with gnome.)

    Help is appreciated, thanks :)

     
  • Robert Gerlach

    Robert Gerlach - 2010-08-27

    Hi,

    install the developer packages for Xorg (at least for Xrandr, Xi, Xext and Xtest), dbus, hal, and xosd. I do not know the names for Linux Mint, for Debian they are libx11-dev libxrandr-dev libxi-dev libxext-dev libxtst-dev libdbus-1-dev libhal-dev and libxosd-dev.

    Regards

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks