fedora core 3 + gcc-3.4.4 build issues

Developers
dualmax88
2005-10-02
2012-12-29
  • dualmax88

    dualmax88 - 2005-10-02

    Hi,

    Apologies for a newbie question, pointers would be greatly appreciated.

    Has anyone tried building GT.M v5 on x86 FC3 with gcc-3.4.4? It fails because of the removal of varargs.h from gcc-3.4.4. Also the pre-built binary fails with a SEGV when run from within the OpenVista install script.

    TIA!

     
    • K.S. Bhaskar

      K.S. Bhaskar - 2005-10-03

      Yes, GT.M still uses varargs,  So, you would need to install a lower version of gcc, one that supports varargs.

      Alternatively, if you are feeling brave and energetic, do make the varargs to stdargs conversion - if you successfully, make the changes, and provide them to us, we will review them and merge them into the permanent GT.M code base.

      Apropos the segmentation violation, please look at http://sourceforge.net/forum/forum.php?thread_id=1353682&forum_id=34583 -- all you probably need to do is to enable executing code from the heap space.

      -- Bhaskar

       
    • Konstantin Aristov

      Hi !

      I have tried to build GT.M v5 x86 FC4 and have made the little patch for conversion from varargs form to stdarg. You can find this patch with instructions in Patches section.

      Sinserely you
                   LittleCat !

       
    • dualmax88

      dualmax88 - 2005-10-27

      Thanks for the SEGV tip Bhaskar and the patch Konstantin! And apologies for the delay in replying. I've been dragged off to do other things. It looks like the patch causes the build to happen just fine. Hopefully, I'll be able to get into this soon...

      Thanks again!

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks