V5.0-000D -Failed to load external dynamic...

Help
2006-05-19
2012-12-29
  • retsis_fabio

    retsis_fabio - 2006-05-19

    I have instaled a new version gtm V5.0-000D but, when I try to use GTM, it gives me the follow error:
    %GTM-E-DLLNOOPEN, Failed to load external dynamic library /usr/local/gtm/libgtmshr.so
    %GTM-E-TEXT, /usr/local/gtm/libgtmshr.so: cannot restore segment prot after reloc: Permission denied

    Can anyone help me

    Thanks in advance

    Fabio

     
    • K.S. Bhaskar

      K.S. Bhaskar - 2006-05-19

      Sounds like something didn't install correctly.  Did you install when running as root?  If so, please reinstall, and post a script of your installation session here.

      Thanx muchly.

      -- Bhaskar

       
      • George James

        George James - 2006-05-19

        I experienced the same problem recently when trying to use GT.M on Fedora Core 5.

        Try disabling SELinux, that solved the problem for me.

         
        • NW Software Engineering

          I didn't want to disable SELinux, and had the problem on an FC5 system.  Using the follow chcon command fixed it.

          chcon -t texrel_shlib_t /usr/local/gtm_V5.0-000C/libgtmshr.so

          I had done a web search on the error message and ound that solution for several application packages.  I shall seek more details about the chcon contexts...

          Walt

           
    • retsis_fabio

      retsis_fabio - 2006-05-19

      I found the solution in http://www.ittvis.com/services/techtip.asp?ttid=3092, see below.

      ----------
      Newer Linux distributions have enabled new kernel security extensions from the SELinux project at the NSA. These extensions allow finer-grained control over system security. However, SELinux also changes some default system behaviors, such as shared library loading, that can be problematic to third party programs.

      If you receive the error message "cannot restore segment prot after reloc: Permission denied" when launching IDL, then your SELinux configuration is preventing IDL from launching.

      To rectify this issue, you can either:

      Change the default security context for IDL by issuing the command:
      chcon -t texrel_shlib_t /usr/local/gtm/*.so

      Disabling SELinux altogether by setting the line
      SELINUX=disabled
      in your /etc/sysconfig/selinux file.
      ---------

      To solve the problem I used this command.
      chcon -t texrel_shlib_t /usr/local/gtm/*.so
      It's running until now.

       

Log in to post a comment.