#1 setting homepage shows "firefox updated" page each login

closed
nobody
None
5
2009-03-23
2006-04-27
Anonymous
No

If you set the homepage setting, the firefox_login.vbs
will execute the following lines to set the homepage in
prefs.js each time the user logs in:

RemoveCurrentPrefsFromFile("browser.startup.homepage")
set HomePageSet =
AppendPrefsToFile("browser.startup.homepage", chr(34) &
HomePageKey & chr(34))

The problem is that
RemoveCurrentPrefsFromFile("browser.startup.homepage")
also removes the setting
"browser.startup.homepage_override.mstone" from the
prefs.js file, and if that setting isn't there, firefox
thinks it just updated and it will show the "Welcome to
firefox" page instead of the homepage you wanted to set.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    suggested fix:

    replace the line
    RemoveCurrentPrefsFromFile("browser.startup.homepage")
    with
    RemoveCurrentPrefsFromFile("browser.startup.homepage""")

    it works for me...

     
  • Nobody/Anonymous

    Logged In: NO

    OR - You could fix it at the function level
    In the function RemoveCurrentPrefsFromFile (in firefox_login.vbs)

    Change the line that looks like this :-
    aContentsNew = Filter(aContents, removeSetting, False, vbTextCompare)
    to this :-
    aContentsNew = Filter(aContents, """" & removeSetting & """", False, vbTextCompare)

    Adding double quotes, to the remove string for the filter statement, should match, what you want to remove, exactly.

    no fudging! ;)

    Matt.

     
  • Mark Sammons

    Mark Sammons - 2009-01-27
    • status: open --> closed
     
  • Mark Sammons

    Mark Sammons - 2009-01-27
    • status: closed --> wont-fix
     
  • Mark Sammons

    Mark Sammons - 2009-03-23

    fixed in 0.4.0.1

     
  • Mark Sammons

    Mark Sammons - 2009-03-23
    • status: wont-fix --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks