#3173 gopenmol-py-3.00-1000

closed
5
2009-05-02
2008-03-10
No

Convert gopenmol packaging to gopenmol-py for python 2.4 and 2.5 variants. Additional changes...

1) Fix -lGL linkage under Leopard.
2) Switch to gcc43 from gcc42.
3) Increase optimization to -O3.
4) Added patch for compiling under gcc43.

The current packaging is complete with one exception. The
package still installs in gOpenMol-3.00 which needs to
be changed to gopenmol-py##.

Discussion

  • Jack Howarth

    Jack Howarth - 2008-03-10

    Logged In: YES
    user_id=403009
    Originator: YES

    File Added: gopenmol-py.patch

     
  • Jack Howarth

    Jack Howarth - 2008-03-10

    gopenmol-py-3.00-1000 patch file

     
  • Jack Howarth

    Jack Howarth - 2008-03-10
    • assigned_to: nobody --> dmacks
     
  • Jack Howarth

    Jack Howarth - 2008-03-10

    Logged In: YES
    user_id=403009
    Originator: YES

    1) Move install subdirectory from gOpenMol-3.00 to %n
    2) Use profie.d scripts to provide access to bin subdirectory

    Now completely passes fink -m build.
    File Added: gopenmol-py.info

     
  • Jack Howarth

    Jack Howarth - 2008-03-11

    gopenmol-py-3.00-1000 info file

     
  • Jack Howarth

    Jack Howarth - 2008-03-11

    Logged In: YES
    user_id=403009
    Originator: YES

    Add symlink to %p/lib/BWidget-1.7.0 in %i/lib/%n/lib so that BWidgets can be found.
    The relocated gopenmol doesn't seem able to find BWidget otherwise. I am actually
    puzzled as to how the stock build finds it since there doesn't seem any effort by
    configure to locate it and the bwidgets package seems to be restricted to its own
    directory. The relocated gopenmol seems to work fine with this change.
    File Added: gopenmol-py.info

     
  • Jack Howarth

    Jack Howarth - 2009-05-02
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks