#3 Gnome-libs fail to compile

closed-fixed
nobody
None
5
2001-04-03
2001-04-02
Anonymous
No

Gnome-libs gives me a IMLIB_Config error when I
try to install it:

checking for imlib-config... no
checking for IMLIB - version >= 1.9... no
*** The imlib-config script installed by IMLIB could
not be found
*** If IMLIB was installed in PREFIX, make sure
PREFIX/bin is in
*** your path, or set the IMLIB_CONFIG
environment variable to the
*** full path to imlib-config.
checking for imlib-config... (cached) no
checking for IMLIB - version >= 1.8... no
*** The imlib-config script installed by IMLIB could
not be found
*** If IMLIB was installed in PREFIX, make sure
PREFIX/bin is in
*** your path, or set the IMLIB_CONFIG
environment variable to the
*** full path to imlib-config.
configure: error: *** IMLIB 1.8 not installed - please
install first ***
### ./configure failed, exit code 1
Failed: compiling failed

Whats interesting is the IMLIB_Config is in /sw/bin
but Gnome-libs isn't seeing it. Odd.

Discussion

  • Christoph Pfisterer

    Logged In: YES
    user_id=51640

    This happens because /sw/bin is not in the PATH when you
    try to build gnome-libs. Codes has been added to CVS
    recently to automatically add /sw/sbin and /sw/bin to the
    path while Fink runs. If you don't want to get the CVS
    code, the workaround is to use the init.sh / init.csh
    scripts to set PATH and other environment variables before
    you run Fink.

     
  • Christoph Pfisterer

    • status: open --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks