#1098 Invalid OSGI manifest header

2.0.3
closed-fixed
None
5
2014-06-21
2012-07-19
No

Artifact com.google.code.findbugs:annotations:2.0.0 contains invalid header in it's MANIFEST.MF and OSGI runtime reports this problem:

276 INSTALLED findbugsAnnotations_2.0.0
osgi> diag 276
reference:file:dropins/libs/plugins/annotations-2.0.0.jar [276]
Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.5

Header Bundle-RequiredExecutionEnvironment should have J2SE-1.5 as it's value not JavaSE-1.5.
See http://wiki.osgi.org/wiki/Execution_Environment for valid values.

p.s. also please consider adding valid OSGI manifest to other findbugs artifacts (e.g. com.google.code.findbugs:jsr305).
p.p.s. findbugs 2.0.1 was released bug i still don't see it on maven central.

Discussion

  • William Pugh

    William Pugh - 2012-07-25
    • assigned_to: nobody --> wpugh
     
  • William Pugh

    William Pugh - 2012-07-25

    OK, the 2.0.1 release contained the update, although it listed the bundle as 2.0.0. I'm updating that, and I'll work on getting stuff into the maven repository.

     
  • Andrey Loskutov

    Andrey Loskutov - 2014-06-21
    • status: open --> closed-fixed
    • Group: --> 2.0.3
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks