AC3 S/PDIF Encode Mode Errors Out App

  • Doug Dudenhoeffer

    I'm a long time user of ffdshow… mainly through getting the shark codecs.  I was having issues with AVI files being able to play 5.1 audio in Windows 7 Media Center, so I upgraded to the Shark 3.6 codec pack and have nothing, but problems.  It did fix the issue with not getting 5.1 in AVI files, but now I'm unable to get 5.1 in mp4 AAC files.  I know I have to encode on the fly the AAC to AC3… 99% sure this is what I was doing before. 

    So now when I have "AC3 S/PDIF Encode Mode" checked in the output section of the ffdshow audio settings, it will cause any player to crash.  If I uncheck "AC3 S/PDIF Encode Mode" it will play fine, but then of course I only get 2 channel audio.

    I completely reformatted and rebuilt my machine from scratch.  Without installing anything accept for Windows critical updates, I still have the problem.  With AC3 encode mode checked on the output section, it will crash any player… I tried WMP, the render option in shark's package, and the render option in graphstudio.  Again, if I uncheck AC3 encode mode all of those work fine, but I only get 2.0 audio… hence why I'm trying to encode as AC3 on the fly so I can get 5.1. 

    I was thinking maybe the version that came with shark codecs was bad.  So I came here and got the latest release which I think came out yesterday.  I installed that, setup my settings, and the same thing happens. 

    I have WIndows 7 x64 (however I'm just trying to get just 32bit to work.  I will worry about 64bit for media center later)
    -ATI Radeon HD 3200 Graphics with latest driver
    -Connect from pc via HDMI to Denon 2309ci AVR then from AVR via HDMI to Samsung TV. 

    All other files I can get to play fine.  Anything thing with Dolby Digital or DTS plays fine and I get 5.1 and the AVR will say Dolby Digital or DTS so I know it is true 5.1.  I'm simply trying to encode aac to ac3 on the fly so I can get 5.1 out of my mp4 files that have aac. 

    Any suggestions?  I have already rebuilt my laptop cleanly with no junk on it and I still have the problem. 


  • Doug Dudenhoeffer

    FIXED!!! FIXED!!! FIXED!!! FIXED!!! FIXED!!! FIXED!!! FIXED!!!… well, fixed for me anyway.  There is an apparent bug in later versions.  Please read below…

    So I got to thinking deep on this one!… what changed because I was 99% certain it was working before. What changed was I downloaded Shark 3.6 going from version 2.x. So I thought, ok, I narrowed the issue down to the ac3 encoding option which is in ffdshow. So, I went to ffdshow's site and downloaded an older version… ffdshow_rev3190_20100109_clsid to be exact. Guess what… it freak'n works now!!! I'm so excited! I had to have a drink in celebration!

    So whatever version of ffdshow comes with shark 3.6 codecs and then the latest one on here has the problem.  The older one I downloaded fixed the problem for me!

    Now, hopefully what fixed the avi 5.1 problem in the shark 3.6 codec's still works. I think it will because I don't think it uses ffdshow… it uses lav.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks