Thanks for providing this.
> this is the next version of the patch. I placed braces where they belong,
> and renamed volume variable to outputPair.
Ok, I see. In this context I agree that the singular makes sense.
> I want to note that the bitmap is in the app space configuration; for each
> bit of it, one control (outputPair) is created.
> Therefore I stayed with singular. The whole group of controls is called
This seems fine to me.
> In DBUS, the naming is .../Settings/VolumeKnob/Line1Line2 --
Do you consider this patch to be ready to commit at this point? I have no
objections at this stage. I think Phil was going to confirm that it has no
effect on other devices. So long as Phil reports no issues with his devices
I'll be happy to commit this.