Le samedi 10 novembre 2012 à 09:27 +0000, Tobi Kraus a écrit :
Hey Phillipe,

Internet = http://subversion.ffado.org/browser/trunk?rev=2218 (per zip File)
konsole = svn checkout http://subversion.ffado.org/ffado/trunk/libffado ffado-svn

 I know it should be the same, but somehow Internet works, Konsole does not. In Both cases i store it in home/tobi/... but 2252 is compiling now, so this is not a "real" problem.

The Mixer just wont open up:

tobi@Studio:~$ ffado-mixer
bash: /usr/bin/ffado-mixer: Keine Berechtigung
tobi@Studio:~$ sudo ffado-mixer
[sudo] password for tobi:
sudo: ffado-mixer: Befehl nicht gefunden

in usr/bin there is a ffado-mixer as Typ "python script" but no "Programm". Should there be a program or is something wrong with my python installation or am i completly wrong?

Yes ffado-mixer is a python script. So you need a python interpreter to run it. Have you ever run ffado-mixer before ? Possibly, python or PyQt and so on are missing in your config.

Now, had you a try with jack (through qjackctl ?) or do you also experience problems ?

Sorry for my problems and thanks alot for yout help!!


Von: Philippe Carriere <la-page-web-of-phil.contact@orange.fr>
An: Tobi Kraus <superkrausi@yahoo.de>
CC: "ffado-user@lists.sourceforge.net" <ffado-user@lists.sourceforge.net>; ffado-devel@lists.sf.net
Gesendet: 10:06 Samstag, 10.November 2012
Betreff: Re: Information required for enabling mixer/router for Firestudio Tube

Le samedi 10 novembre 2012 à 08:50 +0000, Tobi Kraus a écrit :

Hey Phillipe,

i downloaded 2218 from internet. It compiles fine!
i did svn update -r2218 in the latest ffado svn folder(2252) (download per konsole with "svn checkout http://subversion.ffado.org/ffado/trunk/libffado ffado-svn") and it gives me the error below

i downloaded 2252 from Internet compiling works..

so what is going wrong??

What do you mean by downloading from internet ? Whatever you do, you are downloading from internet ??
Probably you are not storing at the same place and so most probably you have a problem with your search path.

2nd Problem:

i cannot start the mixer.

open a terminal window and do:

$ ffado-dbus-server

(in order to have a clearer view of the messages coming from the bus and the ones coming from ffado-mixer) and open another terminal window and do

$ ffado-mixer

If something goes wrong (after starting) you will rerun these command lines with adding a verbose level  (ffado-dbus-server -v 3, for instance).
usually (the two times i tried month ago) i start it with "mouse":  Audio Production -> Mixers -> FFADO Mixer

and it tells me Keine Berechtigung (not allowed) with sudo ffado-mixer in console it tells me "not found".

How can i start the mixer at all???


Von: Philippe Carriere <la-page-web-of-phil.contact@orange.fr>
An: Tobi Kraus <superkrausi@yahoo.de>
CC: "ffado-user@lists.sourceforge.net" <ffado-user@lists.sourceforge.net>; Jonathan Woithe <jwoithe@just42.net>; ffado-devel@lists.sf.net
Gesendet: 19:12 Freitag, 9.November 2012
Betreff: Re: Information required for enabling mixer/router for Firestudio Tube

Le mardi 06 novembre 2012 à 19:02 +0000, Tobi Kraus a écrit :
So, finally we got it ;)

Hi Tobi,

with last revision 2252 of the svn trunk, you would have access to a coherent mixer/router for your device (valid only for Firestudio Tube). As you imagine, I was not able to test anything except compilation on my own PC. So test the things as progressively as possible.

First, since you have probably a yet installed svn, it is preferable to do:

$ scons -c install

in order to uninstall correctly your old install.
Then, svn update and check you update to 2252. Then compile as usual, checking for any strange things.

If install works (there is no good reasons it doesn't), run ffado-dbus-server in a terminal window and ffado-mixer in an other window. Check and report for any warning or error message. Of course, stop the test at any point where there would be an error.

If everything is OK, and as I think you use qjackctl, so run it and then start jack.
Have a look in the connection window of qjackctl, and check if every input/output seem coherent.

If so,  go to the crossbar router section of ffado-mixer. Once again, check if everything looks fair.
If so, it would remain to test the routing: of course, change only one setting after the other with an eye to any message in the different windows.

Hope it works.


Von: Philippe Carriere <la-page-web-of-phil.contact@orange.fr>
An: Tobi Kraus <superkrausi@yahoo.de>
Gesendet: 19:51 Dienstag, 6.November 2012
Betreff: Re: Information required for enabling mixer/router for Firestudio Tube

Le mardi 06 novembre 2012 à 18:25 +0000, Tobi Kraus a écrit :
Hey Philipe,

so the two files are attached by now. I just do not understand why the same command two times produces different output ;)

Sorry, I mistook. The second command is (there is an additional -a):

$ test-dice-eap -c 1 -a --port=fw1 >& test-dice-eap_a.log

By the way, in the Log file i have seen the Port names with Line1 and Tube1 and Mic1 and so on...it would be great to have these names in Jack appearing to. Nad i know it worked some time ago. Perhaps one could decide while building if one would have the possibility for the actual naming scheme or to use names provided by the Interface. (I know, this was made for multiple devices etc. but in my case i just liked the clear names provided by the interface...)

So have fun with the log files;) I will send more output if Running Windows with firewire card;)

Greetz, Tobi

Von: Philippe Carriere <la-page-web-of-phil.contact@orange.fr>
An: Tobi Kraus <superkrausi@yahoo.de>
CC: "ffado-user@lists.sourceforge.net" <ffado-user@lists.sourceforge.net>
Gesendet: 19:04 Dienstag, 6.November 2012
Betreff: Re: Information required for enabling mixer/router for Firestudio Tube

Le lundi 05 novembre 2012 à 22:06 +0000, Tobi Kraus a écrit :
Hey Phillipe,

Hi Tobi,

im on my linux machine again.


The Routing on a windows machine is not possible at the moment, so i only attach the first command. (But the second one is the same (exept the routung that is not possible), so i do not send it again ;) )

Sorry, I was not sufficiently clear in my email. So, run first this command line:

$ test-dice-eap -c 1 --port=fw1 >& test-dice-eap.log

and then

$ test-dice-eap -c 1 --port=fw1 >& test-dice-eap_a.log

which will create two log files, test-dice-eap.log and test-dice-eap_a.log. Send me these log files as attached ones in an email.

Note that, even if you didn't have access to windows up to now, I whatever need the second file to do something. It is just possible that some informations will be missing, but might be added in the future.

Thanks a lot for your effort!!


PS: A mixer is working somehow but very confusing to me, i use the Firestudio tube interface but there are somehow more channels/ inputs shown than there really are....?!

Of course, using the mixer in the present state is fully confusing since you don't really know what is what :-)



Von: Tobi Kraus <superkrausi@yahoo.de>
An: Philippe Carriere <la-page-web-of-phil.contact@orange.fr>
Gesendet: 11:26 Samstag, 13.Oktober 2012
Betreff: Re: Information required for enabling mixer/router for Firestudio Tube

Hey Philippe,

im not curently at my linux machine (400km away ;) ) so i will send the outputs in about 2 weeks. Thanks for your effort of getting the device working properly!!


Von: Philippe Carriere <la-page-web-of-phil.contact@orange.fr>
An: Tobi Kraus <superkrausi@yahoo.de>
CC: "ffado-user@lists.sourceforge.net" <ffado-user@lists.sourceforge.net>
Gesendet: 10:36 Samstag, 13.Oktober 2012
Betreff: Information required for enabling mixer/router for Firestudio Tube

Hi Tobi,

as we know Firestudio Tube is an "EAP" device, that it is not well configured by automatic settings, it could be possible to encode specific settings provided I have more information about it and if Presonus did not prevent this possibility by strange firmware encoding.

Could you:
    - first check that the command line:

        $ test-dice-eap -c 1 --port=fw1

    does not return an error; if so, send me the corresponding output. Else, forgot the following.

    - if you have such a possibility, under Windows/Mac OS, set your device such that all the "DAW" outputs are routed somewhere (for instance using the mixer inputs). If not, there will be some missing informations, but you can still do the next.

       Then, reboot on Linux and do the command line:

        $ test-dice-eap -c 1 -a --port=fw1

    and send me the output (as it is a rather long output, you will probably redirect the output to a file using >& at the end of the command line).