Le mardi 22 mai 2012 à 19:57 +0200, Yves Grenier a écrit :
Le 21/05/2012 18:54, Philippe Carriere a écrit :
Le vendredi 18 mai 2012 à 15:19 +0200, Yves Grenier a écrit :
Le 17/05/2012 10:32, Philippe Carriere a écrit :
Hi Yves,

looking further to your output let me wondering. Could you:
1- run
    $ test-dice-eap -c 1 -a --port=fw1
and keep the output (it will be a long output).
2- reset your Pro 24 under Windows
3-  reboot with Linux and run another time
    $ test-dice-eap -c 1 --port=fw1
    $ test-dice-eap -c 1 -a --port=fw1
and of course keep the output.
4- Check that the error repeats with this reset configuration.
5- If the error has disappeared, run
    $ set-default-router-config-dice-eap --samplerate=48000 --port=fw1
and repeat the two test-dice-eap run.
6- Check if error occurs.

Hi Philippe,

I followed steps 1 to 4. In step 4, I still see the same error with ffado-mixer:
KeyError: dbus.String(u'')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ffado/widgets/crossbarrouter.py", line 176, in updateLevels

I have seen no error in the logs corresponding to steps 1 and 3 of your request. Do you want me to send you the logs?

Hi Yves,

so the error does not seem to come from a misconfigured router (and peak space); I somewhat "hoped" so, in which case there would probably have some erroneous setting for Pro 24.

On the other hand, I think I remember having encountered this kind of error and I imagined that it was probably related to mismatching versions of ffado-mixer, ffado-dbus-server and libffado; more precisely, I observed that the content of /usr/lib/python2.7 was not refreshed using scons and need to be first manually erased, then running scons. Did you act so when you installed the svn version of ffado ? Otherwise, you could quite easily re-install the python2.7 directory in this way and have a try.

Hi Philippe

Here is what I tried:

sudo rm -R /usr/lib/python2.7/sites-package/ffado
cd $HOME/bin/ffado-svn/libffado (this is the directory where I build ffado
rm -R cache
rm .sconsign.dblite
svn checkout http://subversion.ffado.org/ffado/trunk $HOME/bin/ffado-svn

But now many things seem broken, ffado-test Discover gives:

01161040498: Warning (Configuration.cpp)[  67] openFile: Could not parse file: /usr/share/libffado/configuration
01161108826: Debug (devicemanager.cpp)[ 358] discover: Starting discovery...
01161342518: Error (ieee1394service.cpp)[ 750] doFcpTransaction: FCP transaction didn't succeed in 2 tries
01161342541: Warning (ieee1394service.cpp)[ 725] transactionBlock: FCP transaction failed
01161342566: Error (bebob_avdevice.cpp)[  96] probe: Number of channels command failed
01161393015: Error (ieee1394service.cpp)[ 750] doFcpTransaction: FCP transaction didn't succeed in 2 tries
01161393224: Warning (ieee1394service.cpp)[ 725] transactionBlock: FCP transaction failed
01161443020: Error (ieee1394service.cpp)[ 750] doFcpTransaction: FCP transaction didn't succeed in 2 tries
01161443199: Warning (ieee1394service.cpp)[ 725] transactionBlock: FCP transaction failed
01161443247: Error (avc_avdevice.cpp)[  89] probe: Subunit info command failed
01161443351: Debug (devicemanager.cpp)[ 665] discover: Discovery finished...
01161443388: Debug (devicemanager.cpp)[1269] showDeviceInfo: ===== Device Manager =====
01161443430: Debug (Element.cpp)[ 121] show: Element DeviceManager
01161443451: Debug (devicemanager.cpp)[1277] showDeviceInfo: --- IEEE1394 Service  0 ---
Iso handler info:
Dumping IsoHandlerManager Stream handler information...
 State: 2
no message buffer overruns

However ffado-test ListDevices correctly list the devices:
=== 1394 PORT 0 ===
  Node id  GUID                  VendorId     ModelId   Vendor - Model
   0       0x00130e0401c00f89  0x0000130E  0x00000007   Focusrite - SAFFIRE_PRO_24
   1       0x0017fb340000e0f4  0x000017FB  0x00000000   Linux Firewire -

What is the first warning? /usr/share/libffado/configuration is present and seems correct. Have I broken something by my reinstallation?

I think that somewhere, you have not a clean install of ffado; try a scons -c install, have a look to undesirable remaining files (more particularly in /usr/lib/python2.7/sites-package/ffado/, but also have a look in /usr/bin, /usr/share/libffado), apply the scons procedure following what is described on the ffado-site: since you install over a package distro - something I didn't make up to now - it is possible that something does not install and it has to be forced. Didn't you have a discussion recently about this ? You must probably follow the same line.



jackd fails with the same message about doFcpTransaction.

ffado-mixer says "No supproted device found".



Philippe Carriere <la-page-web-of-phil.contact@orange.fr>