Hi All,
Sorry to bother you again.
I managed to fix my last problem with Linux but now I'm greeted with a new one. The error message is similar to the last one but not caused by the same reason:-
1. I created a new record-type called Qualicat in Windows and it's working fine.
2. I deleted all the XSDs on my Linux server.
3. I imported all the Windows XSDs back into Linux.
4. I created a community and a collection to keep my QC records organised. (this works fine)
5. I then try to create a QC record in Linux and when I hit "publish" I get this message:-

Warning: Invalid argument supplied for foreach() in /opt/lampp/htdocs/archive/include/class.record.php on line 686

Warning: implode() [function.implode]: Invalid arguments passed in /opt/lampp/htdocs/archive/include/class.record.php on line 703

Warning: Invalid argument supplied for foreach() in /opt/lampp/htdocs/archive/include/class.record.php on line 722

Fatal error: Call to a member function getXSD_HTML_Match() on a non-object in /opt/lampp/htdocs/archive/include/class.record.php on line 3374
I got this error before and Bernadette helped me fix it (a problem in the RELS-EXT).  However, it can't be a problem with RELS-EXT this time because it works fine with Windows. I've checked (many times) my XSD_MF references and they're correct.
I've also tried creating the Qualicat record type thorugh Linux manually and I also get the same problem. I've tried re-installing Fez and I'm using the correct workflows. This is my reasoning about the problem so far:-
1. It can't be a problem with my Fedora set up because I'm able to create new communities/collections.
2. I don't think it's my XSDs because they work with Windows
3. My config settings should be correct  because I can create records with the default document types
I say that my config settings should be correct as the sanity checks pass except for this error:-

"Failed: ConnectHTTP APP_BASE_FEDORA_APIM_DOMAIN = 'http://fedoraAdmin:XXXXXXXX@localhost:8080/fedora' HTTP Result 401 code. The webserver couldn't connect to this address. Check that the address is correct. Check that any authorisation needed is correct. Perhaps it is blocked at a firewall.
If the fedora server responded with a 401 code, then maybe the security settings aren't right. Check that you supplied the correct password in the Fez config. Ensure APP_FEDORA_SETUP is correct. Set fedora.fcfg option <param name="ENFORCE-MODE" value="permit-all-requests"/> to allow requests from remote hosts (or taylor to suit your security requirements - default seems to let through localhost only) "
The only way that I can get rid of this error is by changing my Fedora URL to http://localhost:8080/fedora/ (note the trailing /) but doing this causes errors when I create communities.
I've included a copy of my XSDs.  It's not a complete version of what Qualicat will eventually be but it should be complete enough to not cause errors! (PS Qualicat is just Dublin Core with a few extra fields added in for our own convenience).
Anyway I hope that someone can help.