Hi Christiaan,
 
* Confirmed that I am indeed running PHP 5.2.25
 
* Sohusin is new to me,  php.info provides the following note: "This server is protected with the Suhosin Patch 0.9.6.2"
however YaST indicates that the php5-suhosin module is not installed.  I am thinking that I might have to do a manual install of php5.
 
 
* Looking at error_handler.log gives some clues,  "Record slsa:420 doesn't exist" appears several times and other messages complain that it can't reference this record. 
 
(
    [txt] => Array
        (
            [0] => Record slsa:420 doesn't exist
        )
 
    [script] => include/class.record.php
    [line] => 2139
    [ip] => IP Address '143.216.224.41' - (143.216.224.41) coming from the page (referrer) 'http://doms.slsa.
sa.gov.au/fez/workflow/enter_metadata.php?id=15&wfs_id=775'.
    [backtrace] => Array
        (
            [0] => Array
                (
                    [file] => include/class.record.php:2139
                    [call] => Error_Handler->logError"Record slsa:420 doesn't exist", "/srv/www/htdocs/fez/in
clude/class.record.php", 2139
                )
 
Does this offer any help to the trained eye?  
 
regards
sean


From: fez-developers-bounces@lists.sourceforge.net [mailto:fez-developers-bounces@lists.sourceforge.net] On Behalf Of Christiaan Kortekaas
Sent: Thursday, 31 January 2008 2:29 PM
To: fez-developers@lists.sourceforge.net
Subject: Re: [Fez-developers] Fez 2 not accepting items

Hi Sean

Have a look in your error_handler.log log file and see if that gives some more clues. Do you have Sohusin installed? If so perhaps try disabling it. Are you running PHP5 or 4? Fez needs PHP5.

Cheers,
Christiaan


On 31/1/08 1:45 PM, "Abel, Sean (SLSA)" <Abel.Sean@slsa.sa.gov.au> wrote:

I have hit the next little obstacle in my Fez install.

While attempting to add a community, collection or record I get the following error:

Fatal error: Call to a member function getXSD_HTML_Match() on a non-object in /srv/www/htdocs/fez/include/class.record.php on line 2338
 
from the error logs I find:
The PID slsa:412 does not have an display id (FezMD->xdis_id). This object is currently in an erroneous state.
When I look at the FEDORA search interface I can see that a FEDORA object has been created for each attempt to add via Fez, however they are missing every second PIDs.  ie slsa:407, slsa:409, slsa:411 etc

Any ideas as to where I should start looking?   

Server setup:
SUSE 10.3
FEDORA  2.2.1
Fez 2.0
MySQL 5
regards
sean

Sean Abel

Digital Object Management, ICT

State Library of South Australia

Phone:  +61 8 8207 7601

Fax:       +61 8 8207 7350

Email:    abel.sean@slsa.sa.gov.au

http://www.slsa.sa.gov.au <http://www.slsa.sa.gov.au/>

Please don't print this e-mail unless you really need to.

The information contained in this e-mail message may be confidential, and may also be the subject of privilege or public interest immunity.  This e-mail and any attached files should be scanned to detect viruses and no liability for loss or damage resulting from the use of any attached files is accepted.  If you are not the intended recipient, any use, disclosure or reproduction of this document is unauthorised.  If you have received this e-mail in error please telephone +61 8 8207 7601.

 


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/

_______________________________________________
Fez-developers mailing list
Fez-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/fez-developers


--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Christiaan Kortekaas
Senior Library Open Sorcerer
Library Technology Service
The University of Queensland, Australia QLD 4072
Telephone : (+61) (7) 3346 4337
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~