Hi Christiaan,

I am fairly sure one of the record that we created contains that new object we uploaded. Not sure if this is categorized as object was saved with pdf but there is error message.

We were just upload a new pdf on current record and what happened was as soon as we clicked publish, small window popped-up, showing the same error along with debug info but then it disappeared, whereas on the main window, it redirected us to the page that we were once belong. In that page (view.php) we can see that our new pdf was there. We can download and open it without problem.

Also, we previously already had set our 'upload_max_filesize' and 'post_max_size' to 20 M which we reckon that should be enough. We can assure you that we had normally posting our document no size bigger than 1 MB each. 

There is one thing, in jhove configuration file, we had set up our JAVA_HOME to /Library/Java/Home instead of the one you mentioned on fez installation instruction. Our Environment variable has the same path as well.

Later on jhove, We tried to set up the path correspond to the one you suggested and then we tested it.. no different. Do we have to re-setup fez if changes on jhove setting has been made?


On 28/08/2006, at 1:02 PM, Christiaan Kortekaas wrote:

Hi Haryo,
Not quite sure if you are succeeding to save the PDF with the object or if only the object is saving with no PDF, or if object saves with PDF but there is an
error message?
If the PDF is not saving perhaps your PDF is too large for your php.ini settings.
"upload_max_filesize" should be something like 70M or more to be safe, it is 2M by default. It depends on how big the files you want to upload are.
"post_max_size" should be at least the upload_max_filesize value of 70M or more. It is also 2M by default.
You have to restart apache to make these changes take effect.
If this is not the solution then can you email me directly the full Fedora error message you are getting? It could be JHOVE is having a problem extracting the
preservation metadata. When you installed JHOVE did you edit the jhove command executable as per the Fez installation instructions?

From: fez-users-bounces@lists.sourceforge.net [mailto:fez-users-bounces@lists.sourceforge.net] On Behalf Of Haryo Septiantoro
Sent: Monday, 28 August 2006 2:18 PM
To: fez-users@lists.sourceforge.net
Subject: [Fez-users] create record problem

Hi all,

Has anyone found problem while creating a new record under your collection? 
We catch an error message which is:

ERROR: Array ( [0] => Array ( [faultcode] => soapenv:Server.userException [faultstring] => fedora.server.errors.GeneralException: Error with : Error getting [detail] => Array ( [hostname] => scca-staff-hseptiantoro.local ) ) [1] => 

Seems that our hostname was being the problem so far we look. 

But the interesting was if we then check on our collection, the new object was there. We can download and open that file, no problem. At the moment we were trying to ingest a pdf file. 

Any thoughts anyone?

Haryo Septiantoro
Graduate Research Assistant
School of Communications & Contemporary Arts
Edith Cowan University
Mount Lawley Campus
2 Bradford St
Mount Lawley, WA 6050
Tel: +61 8 9370 6409

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
Fez-users mailing list