Hello Fez users,

 

we are experimenting with Fez/Fedora and a collection of existing records and am trying to understand how everything works. The existing records are converted from MARCXML to MODS and finally to individual (per record) FOXML XML-Files (with a MODS datastream) which are successfully imported into Fedora using a fedora-ingest batch.

 

From there, the objects are indexed into Fez using the “Generic Document MODS” type. So far everything worked well. However, since our authors don’t have a role (author/editor) specified in the MODS, we tried to adjust the XSD mapping for the “Author(s)” to go without the indicator (which is set to role!roleName=author or something like that). But we didn’t succeed because it was not possible to update the author (a yellow error message appeared). Also, when deleting and trying to add a new “XSD Looping Subelement”, the message “An error occurred while trying to add the new xsd looping subelement.” appears.

 

It is unclear to me whether I have a problem understanding the architecture – or if there is a problem with the interface. Everything seems quite complex and dependant, so any help or documentation to clear this up is greatly appreciated.

 

Best regards,

Kai

 

 

--

Kai Jauslin, Dipl. Informatik-Ing. ETH, ETH Zürich, ETH-Bibliothek, Rämistrasse 101, CH-8092 Zürich

kai.jauslin@library.ethz.ch, Tel +41-44-6324972, Büro STB F19