Hi Conor, I had the same problem last week, and ended up re-using an existing document type that we didn’t need. Haven’t yet tried Jonathan’s solution (his email to the list of 24 June).


We noticed the problem after our most recent upgrade. Which means things were most likely working OK in the upgrade before that, viz. May 2011.




From: McTernan, Conor [mailto:mcternan@unu.edu]
Sent: Tuesday, 26 June 2012 11:39 AM
To: fez-users@lists.sourceforge.net
Subject: Re: [Fez-users] unable to add cloned documents to collection


Any luck cloning and adding docs successfully?


I have been struggling with this for close to a week now and am making no progress.

I have re-install fez/fedora using the most recent version of fez from the mercurial repo and using fedora 3.5. If I use the default doc types I have no problem adding documents, but once I clone a document type I am unable to create new documents using this new type.  


Here is the process I am using to clone the document (I believe this worked on a version of fez from a month or two ago):

         Taking Books as an example export the 3 XSDs (Fedora Object XML -> Book MODS 1.0, MODS -> Book MODS 1.0, OAI DC -> Book MODS DC Display).

o   I export these as one file via the import/export tool

         I then update the xdis_title values prefixing them with “My” e.g. “My Book”, “My Book MODS” and “My Book MODS DC Display”.

         I also clear all xsdmf_id values. E.g. xsdmf_id=””

         I then re-import the update xsd file

         Associate the different doc types

o   FOXML -> Edit Displays -> My Book -> Edit


         update the XSDMF ID Reference to point to the new My Book MODS Version 1.0

         Select (Title)!titleInfo!title

         Save “Value”


         For the DC datastream set the XSD Display to My Books MODS DC Display

         For the MODS datastream set the XSD Display to My Books MODS

         Then edit the OAI DC

o   OAI DC -> Edit Displays -> My Book MODS DC Display -> Edit


         Update XSDMF ID Reference to point to “My Book MODS”


         Select “Value”


From all the guides and tutorials these seem to be the steps to take to clone and then re-associate doc types. If I am missing any steps or if I am doing some of them wrong I would really appreciate some help.


At this point this is becoming a bit of a problem for us and I would really like to get past this. Alternatively if there is a particular version of Fez known to work I could install and work with that.


Thanks in advance,




From: Bernadette Houghton [mailto:bernadette.houghton@deakin.edu.au]
Sent: Friday, June 22, 2012 12:52 PM
To: fez-users@lists.sourceforge.net
Subject: Re: [Fez-users] unable to add cloned documents to collection


Hi Conor, I’ve been spending the past 24 hours working on cloning of doc types. I ended up repurposing an existing, unused document type, rather than a cloned version. Have just now finished!


I did follow the previous listserv thread, Subject: XSD HTML Matching Editor, clearing out all xsdmf_id values at both the FOXML and the FOXML-MODS-OAI-DC levels. But each time when saving a newly-created document, I received a similar error to yours; mine was “Fatal error: Call to a member function getTitle() on a non-object…”. I also tried exporting a similar doc type, clearing out the xsdmf_id values and then reimporting. Still no go.


Sorry, no help to you.