Difficulties getting Fez Installed

Help
mrLobo
2007-08-02
2012-10-29
  • mrLobo

    mrLobo - 2007-08-02

    Hi,

    I am trying to get Fez installed for a demonstration at my office and for our consideration of using your system, but I am having several problems getting it up and running. First of all I cannot create any communities. The error that I am getting on screen is:

    Fatal error: Call to a member function getXSDMF_IDByXDIS_ID() on a non-object in /usr/local/fez-1.3/include/class.record.php on line 1501

    In error_handler.log is written the following message concerning this:

    "The PID {} doesn't appear to be in the fedora repository - perhaps it was not ingested correctly. Please let the Fez admin know so that the Fez index can be repaired."
    [line] => 971
    [backtrace] => Array
    [1] => Array
    (
    [file] => include/class.xsd_display.php:936
    [call] => XSD_DisplayObject->processXSDMF()
    )

    Followed by

    "Record doesn't exist"
    [script] => include/class.record.php
    [line] => 1371
    [1] => Array
    (
    [file] => include/class.record.php:1666
    [call] => RecordGeneral->getXmlDisplayId()
    )

    Then the next problem I have is that of not getting graphviz to work. I am not getting any pictures. I have debugged the problem a little bit and I have found out that when I am runnig graphviz with the commands written to the tempfile generated in the function getPNG it does produce an image, but when I am running it via the webservice I am getting no image and I cannot find a reason for it. It does not seem to have a connection with filerights. The following error is produced in the apache erorr log.

    Warning: dlopen(/usr/local/graphviz-2.12/lib/graphviz/libgvplugin_pango.3.dylib, 9): Library not loaded: /usr/local/graphviz-2.12/lib/libpng12.0.dylib
    Referenced from: /usr/local/graphviz-2.12/lib/graphviz/libgvplugin_pango.3.dylib
    Reason: Incompatible library version: libgvplugin_pango.3.dylib requires version 19.0.0 or later, but libpng12.0.dylib provides version 17.0.0Warning: dlopen(/usr/local/graphviz-2.12/lib/graphviz/libgvplugin_pango.3.dylib, 9): Library not loaded: /usr/local/graphviz-2.12/lib/libpng12.0.dylib
    Referenced from: /usr/local/graphviz-2.12/lib/graphviz/libgvplugin_pango.3.dylib
    Reason: Incompatible library version: libgvplugin_pango.3.dylib requires version 19.0.0 or later, but libpng12.0.dylib provides version 17.0.0Renderer type: "png" not recognized. Use one of: canon cmap cmapx dot fig gd gd2 gif gtk imap ismap pdf plain plain-ext png ps ps2 svg svgz wbmp xdot xlib

    It is the only message which I am getting.

    I am sorry to say that I do not have the time to go through a lengthy process of getting Fez up and running, since I am reviewing several application, thus I am hoping you could provide me with some answers that will shorten that time.

    FYI I am running:

    Mac OS x 10.4.10 (tiger)
    Apache 2.0.59 (MAMP)
    MySQL 5.0.37
    PHP 5.2.1
    Fedora 2.2 quick install
    Graphviz 2.12

    I hope you can help me.

    Kind regards,

    lobo

     
    • Matthew Smith

      Matthew Smith - 2007-08-03

      Hi Lobo,

      Don't worry about graphviz - you don't need it. it is just for some admin stuff to help visiualise workflows.

      As for creating communities - check the mailing list for where other's have had this problem. Sorry we don't have time right now to help much. If you know any PHP, you can look at the backtrace and print out some variables to a file to find out where it's going wrong.

      Also have a look at the /setup/check_sanity.php results.

      Matt

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks