patches don't work against latest posted code

Help
2006-10-11
2012-10-29
  • Kyle Fenton

    Kyle Fenton - 2006-10-11

    I've been unable to get any of the three code patches to apply to the code you have posted for download. I think they were diff'd against a previous revision. Can you confirm?

     
    • Kyle Fenton

      Kyle Fenton - 2006-10-11

      As a workaround I'm using a copy of class.misc.php from the cvs repository. Is that class stable enough?

       
      • Matthew Smith

        Matthew Smith - 2006-10-12

        That's odd, I know the patch command is a bit sensitive to the directory from which you run them and the -p param. I will remember to post the datails of how to apply the patches in future. If you can't get them to work from the base dir, try running patch from the /include dir.

         
    • Kyle Fenton

      Kyle Fenton - 2006-10-13

      The hunks in the xsd tree patch reference the incorrect line numbers, e.g. hunk #1 starts at line 1302 whereas the line it references in the downloaded class.misc.php is on line 1300

      Here's how I'm executing from the fez root:
      patch -p0 < xsd_tree_mss1.patch

      I've edited the path in the patch and tried it from the include directory, same results (all hunks fail). I've also tried patch with "-c" and that does not work either

       
      • Matthew Smith

        Matthew Smith - 2006-10-16

        Hi Kyle,

        The batch import patches need to be applied before the XSD patch (sorry I didn't realise this before but they also modify class.misc.php).

        batchimport_mss1.patch - Run from the include dir with -p0

        batchimport_mss2.patch - Run from the include dir with -p0

        xsd_tree_mss1.patch - Run from the fez root dir with -p0

        Matt

         
    • Kyle Fenton

      Kyle Fenton - 2006-10-16

      Alas, it still fails:

      patch -p0 < batchimport_mss1.patch
      patching file class.batchimport.php
      Hunk #1 FAILED at 694.
      1 out of 1 hunk FAILED -- saving rejects to file class.batchimport.php.rej
      patching file class.foxml.php
      Hunk #1 FAILED at 656.
      1 out of 1 hunk FAILED -- saving rejects to file class.foxml.php.rej

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks