Back in January 2014, I had fail2ban working in my Knoppmyth R5.5 machine (Debian etch from 2008).
Then, I tried to update to slightly newer versions of fail2ban and python-central. 
Now, when I try and start or restart fail2ban, I get an error.

root@mythtv:/etc/fail2ban# /etc/init.d/fail2ban restart
Restarting authentication failure monitor: fail2ban failed!

Does anyone know what the error message is specifically indicating?
Is there anywhere else that would give a clue?
The /var/log/fail2ban.log file is empty.

Here are the versions of the components I had running at one time.
I just tried these same versions of the .deb files in a Knoppmyth R5.5 virtual machine, and they work in the virtual machine.

http://archive.debian.net/etch/all/fail2ban  (version 0.7.5-2etch1)
http://archive.debian.net/etch/python/python (version 2.4.4-2)
http://archive.debian.net/etch/all/python-central (version 0.5.12)

For fail2ban, I used the command "dpkg -i fail2ban_0.7.5-2etch1_all.deb"

In my real-world machine, I started with these versions. 
For the newer version of fail2ban, I also needed to update the python-central version to version 0.6.17.
Now, fail2ban won't run.
I have been trying to use the dpkg command to "go back" and overwrite the newer with the older.  dpkg seems to complete the process of installing the older, but when you try and start fail2ban, it doesn't work.  (with the error you see)

There must be some way to get back to a working setup, but I'm not sure how.
Use dpkg to remove and then manually delete all the files from the newer versions?

Help appreciated.
Eric